Can't see changes after new built



I have a strange behaviour on my netlify website project.
The problem:
I don’t see the changes in my website even though they are published.

Project description:
I have a small portfolio website. The site consists of few html pages some css & js files. It is really only a presentation site.

The problem:
I’ve tried to update the FavIcon on the site but I’ve noticed it doesn’t update at all. I’ve tried multiple ways of doing it and it didn’t work.
After around 5 unsuccessful attempts I’ve tried another approach. I’ve published a new website which only had an index.html page and
a “Hello World” message on it, still no changes were applied.
When I download the zip containing latest changes, I can see everything is up to date and good. However, when I open my website through
https://abcd.efg the changes are not propagated at all.

Is there some strange caching that is taking place? If so, how can I clear it so the latest changes will apply? Or maybe I’m doing something wrong?

Thank you in advance.

Best regards,

@covalerica You probably are seeing caching but it’s not strange … it’s usually normal.

Assets such as favicons can persist in their previous state for what seems like a long time. If the correct files are in the correct places and are referenced the correct way(s), they will eventually show.

For favicons specifically, it can be better to check them here that through your local machine / connection: