Build failed when trying to download node.js version


I am trying to deploy one of my branches, when the build tries to download node.js version the build fails
When it’s uses an already installed node.js version. - its finishes the build

The branch work on local machine.

Any ideas why this happen?

Hiya, sorry you are having trouble with your build.

This Support Guide contains a ton of useful debugging tips that can likely help you solve your problem :slight_smile:

We also recommend trying to search the forums with the build error you encountered - it’s likely your question was already asked by someone else!

If you are still having problems, please provide as much information as you can on what you have already tried, what your build settings are, your package.json, etc. Thanks!

Hey @perry,
Thank you for your response.
I already tried to look for information about the problem but didn’t find anything.

I tried to re-deploy the branch with cache and after clearing cache.

The problem is in a specific branch, when I pushed it to master - the build worked and the changes went live.

  "name": "static-website-2018",
  "version": "1.0.0",
  "description": "Breezometer's static website",
  "author": "BreezoMeter Ltd.",
  "private": true,
  "scripts": {
    "dev": "nuxt",
    "generate": "nuxt generate",
    "forestry:preview": "nuxt --hostname --port 8080"
  "dependencies": {
    "@glidejs/glide": "^3.4.1",
    "@nuxtjs/device": "^2.0.1",
    "@nuxtjs/style-resources": "~1.0.0",
    "@nuxtjs/svg": "~0.1.12",
    "@sentry/node": "~6.2.3",
    "@tailwindcss/typography": "~0.4.0",
    "@turf/helpers": "~6.3.0",
    "@turf/nearest-point-on-line": "~6.3.0",
    "axios": "~0.21.1",
    "axios-retry": "~3.1.9",
    "browser-image-compression": "~1.0.14",
    "chart.js": "^2.9.4",
    "chartjs-plugin-annotation": "^0.5.7",
    "cookie-universal-nuxt": "~2.1.4",
    "core-js": "~3.9.1",
    "dayjs": "~1.10.4",
    "dayjs-plugin-utc": "~0.1.2",
    "deepmerge": "4.2.2",
    "file-saver": "~2.0.5",
    "flickity": "^2.2.2",
    "hooper": "~0.3.4",
    "inquirer": "~8.0.0",
    "inquirer-fuzzy-path": "~2.3.0",
    "lazysizes": "^5.3.0",
    "load-js": "~3.0.3",
    "lodash.debounce": "^4.0.8",
    "mapbox-gl": "~2.1.1",
    "nuxt": "~2.15.3",
    "nuxt-i18n": "~6.21.1",
    "nuxt-modernizr": "^1.0.9",
    "pdfobject": "~2.2.5",
    "platform": "~1.3.6",
    "scrollama": "~2.2.2",
    "timeago.js": "~4.0.2",
    "v-tooltip": "^2.1.3",
    "vue-click-outside": "~1.1.0",
    "vue-js-modal": "~1.3.35",
    "vue-observe-visibility": "~1.0.0",
    "vue-scrollto": "~2.20.0",
    "vue-select": "~3.11.2",
    "vue-smooth-reflow": "^0.1.12",
    "vue-spinner": "^1.0.4"
  "devDependencies": {
    "@aceforth/nuxt-optimized-images": "~1.4.0",
    "@nuxtjs/sitemap": "~2.4.0",
    "@nuxtjs/tailwindcss": "~3.4.3",
    "babel-eslint": "~10.1.0",
    "glob-all": "~3.2.1",
    "lqip-loader": "~2.2.1",
    "webp-loader": "^0.6.0",
    "node-sass": "~5.0.0",
    "sass-loader": "~10.1.1"

Hi there, @GalHBrz :wave:

Thanks for your patience here. It looks like it has been a little over a week since you last wrote in. Are you still experiencing this issue? If so, please let us know.

Hey @hillary ,
I got help from the support team via mail.
Needed to delete the node_modules folder and package-lock.json file. Then run npm install - fix the issue

Thank you for replaying

1 Like

Thank you for sharing this with the Forums! It will be beneficial to future members who encounter something similar.