Build error possibly related to Plugin "jsx-a11y"


I’m recently unable to build a deploy preview from my repo. The error I am getting is as follows:

3:07:01 PM: build.command from netlify.toml                               
3:07:01 PM: ────────────────────────────────────────────────────────────────
3:07:01 PM: $ pnpm run build
3:07:01 PM: > vms-frontend@0.1.0 build /opt/build/repo
3:07:01 PM: > react-app-rewired build
3:07:03 PM: Creating an optimized production build...
3:11:02 PM: Failed to compile.
3:11:02 PM: 
3:11:02 PM: [eslint] Plugin "jsx-a11y" was conflicted between ".eslintrc.json » eslint-config-react-app" and ".eslintrc.json » eslint-config-airbnb » /opt/build/repo/node_modules/.pnpm/eslint-config-airbnb@19.0.2_eslint-plugin-import@2.28.0_eslint-plugin-jsx-a11y@6.7.1_eslint-p_j3k7s6vjs5pzd2r7mnsdlwgo6u/node_modules/eslint-config-airbnb/rules/react-a11y.js".
3:11:02 PM:  ELIFECYCLE  Command failed with exit code 1. (
3:11:02 PM: ​
3:11:02 PM: "build.command" failed                                        
3:11:02 PM: ────────────────────────────────────────────────────────────────
3:11:02 PM: ​
3:11:02 PM:   Error message
3:11:02 PM:   Command failed with exit code 1: pnpm run build (
3:11:02 PM: ​
3:11:02 PM:   Error location
3:11:02 PM:   In build.command from netlify.toml:
3:11:02 PM:   pnpm run build

The odd thing is that I have a PR with a deploy preview that does build and if I create a new branch from that and then create another PR, the build fails with the above error. Both branches should be identical, so it is hard to see why it is failing. I have tried “Clear cache and retry…” on both, with the same result.

Any ideas?

Please share the site name.


SIte name is: vms-frontend (

Deploy Preview #628 is failing to build.

This issue has some suggestions: ERROR in Plugin “react” was conflicted between “.eslintrc.json” and “BaseConfig” · Issue #11825 · facebook/create-react-app ( have you tried those?

After trying lots of things, in the end it was solved by adding the following to package.json:

"resolutions": {
  "eslint-plugin-react": "^7.33.1",
  "eslint-plugin-jsx-a11y": "6.7.1"

and then:

pnpm install --no-frozen-lockfile

and finally a Netlify re-deploy with cache deletion.

I’m still unsure of why this has suddenly become necessary after if was deploying successfully before??