Broken Root but index.html exists and works

  • we need to know your netlify site name. Example: gives me a “Page not Found” message but works.

Please help!

Hi there,

Did you see this guide yet? This is the best place to start for “Page Not Found” issues.

If you are still seeing issues after following the troubleshooting steps in this guide, please let us know!

You must have fixed this, because both URLs seem to be showing the same content now.

I have downloaded the build and the index.html file exists.

I am still having the problem. I also tried in an incognito window and cleared my cache.

Sorry - this was a bug in one of our Sydney CDN nodes’ cache. I just got things cleared up and should be working better now - could you confirm?

This works now. Thank you!

1 Like

@fool - I’m experiencing the same problem where I’m gettin getting a “Page not found” error at the root even though you can add /index.html and it works just fine.

I’m sometimes also getting that same error on the non secure version of the real domain, but it always seems to work fine on the secure version

Also odd is there is a redirect setup for the netlify domain to send it to the real domain that doesn’t seem to be kicking in.

Could you take a look? Thanks for your help.

I deleted the site and created a new one (got a new server name), and its working fine now. Definitely something buggy with the old one. I guess “cranky-shannon” earned her name :joy:

1 Like

Good instinct! We have a bugfix in flight for this so hopefully we’ll get that shipped in the near future to prevent recurrence.