Base directory does not exist: /opt/build/repo/dist

Hello, dear support!
Please, help me to fix the deploy:
site name: (fervent-nobel-bd3d73)

Constand build problem:
- Failing build: Failed to parse configuration
*- Failed during stage ‘Reading and parsing configuration files’: *
Base directory does not exist: /opt/build/repo/dist

Please, see the full deploy log attached.
I also attach:

Thanks a lot!
indent preformatted text by 4 spaces


If your base is dist, your publish should probably be angular-firebase-app instead of dist/angular-firebase-app. Please try that and let us know.

EDIT: However, I see that your error is that dist does not exist. From my assumptions, your base should be / and your publish should be dist. That’s what I can say without actually seeing your repository. Basically, base should be the path which Netlify would be using to build, or the one in which your package.json exists and the publish should be the one in which the output code is generated and Netlify can publish it.

Hi Hrish!
Thanks for a quick reply.

No, that didn’t help
Is I change dist - it changes the publish dir too.
I’ve already tried different base and publish dir, the mistake is the same. Maybe the problem is different?


Basically, the base should be a path that already exists in the repo. Does the directory dist exist already or is it generated while your build is generated?

I don’t see it in a repo.
But it exists in my project, when I open it locally. I’ve used Angular framework

Also in a deploy log it says - “Starting to prepare the repo for build”

I haven’t used Angular personally, but, from what I could see here:, the base path is / or blank and publish is what you already have.

Well now when you say it doesn’t exist in a repo, we probably have found the solution.

You can see when you open it locally probably because you’ve developed it locally once and thus, the code is generated in your folder. However, it doesn’t exist on GitHub.

Perfect! thank you so much.
I’ve connected Netlify to my Angular project through CLI and now I can push it live with a simple command.

The problem was solved. Thanks again, Hrishikesh :star_struck: