An authentication secret is NOT automatically generated

I want to recommend updating the docs here: Netlify Email Integration | Netlify Docs

It isn’t clear that you need to do BOTH steps (the UI and the .toml). I thought it would be enough to just configure with the .toml (as I’ve done most other configurations for Netlify) but when I ran the email integration it wouldn’t generate the secret. Only until I also enabled it in the UI did it work.


thank you for reaching out. I have escalated your query to our docs team.

Hi again @ddamato ! Thanks for your patience while we got this sorted with our devs and got the docs updated to mention the requirement you discovered. Let me know if anything there doesn’t make sense now and know that you did find a bug in our docs and so that’s what we fixed :slight_smile: