Runtime.ImportModuleError - Error: Cannot find module 'styled-jsx/style'

@Alexei_Garban, you’re not using 13.4.9, ^ identifier reverts you to the latest non-major version. Remove ^ from that string.

@sherakama, not sure if you’ve seen this: Server.edge not defined Error on nextJS SSR functions cause site to return 500 Errors, but we’re indeed aware of that issue. For quite some time, we tried to play cat and mouse with that and other issues Next.js keeps on creating with each release and it’s basically not working out. We’re shifting the focus to a more robust implementation that would (if it works out), iron out majority of the bugs specific to Next.js on Netlify. So we’re currently not investigating each issue case-by-case, so we can focus more on rolling out something useful instead of continuing this game we’ve been playing.

We’re aiming for something useful this month, but it’s a highly optimistic timeline, so let’s consider this entire quarter to be safe.

1 Like