Resources 404ing after deployment

Hello. I am just starting to use Netlify. I have a Nextjs site. I was having successful deploy previews. Then one deploy wasn’t previewing correctly: Many of the manifest files are 404ing, but the index and some other files load fine. The changes I had made were minor css changes. After a few failed attempts to redeploy (preview) I reverted my repository to the last “good” hash, but it doesn’t return the same deploy preview as previously seen.

Here’s the most recent successful preview:

Here’s the following deploy preview with resources not found:

Here’s the most recent deploy preview, which is the same repo state as the most recent successful preview, but also has resources not found:

I’ve tried these things as well:

  • Updating the build command to use pnpm, and since have reverted it back to running with npm. Neither made a difference.
  • Retry with latest branch commit
  • Clear cache and retry with latest branch commit

I attempted to paste in the last deploy output but this webform disallowed me as it is too many characters.


I think there must be an issue with netlify as my builds have all been working yesterday and as of this morning I am getting multiple 404s all from my _next/static folder. I have sent a support request to netlify about this so hopefully it will be solved (and hopefully that is your issue too).

1 Like

Same thing here. I made one build two hours ago and it was working ok, but half an hour ago there is the same issue that you guys described, with missing static files. It seems like a Netlify wide issue, so we will just have to wait for the fix.

1 Like

Same thing here. Had to redeploy previous build.

We are encountering the same issue with the deployment. Yesterday everything deployed fine, since 2 hours we get the same issue as described by OP. We redeployed our production site today after updating a Environment variable and now our production site is down completely because of this issue. Changing the Environment variable back doesn’t solve it.

Update saying they’re looking into it

hi folks! we’re actively working on the incident. We’ve reverted a change, can you please retry the build now?

1 Like

Yes, previews seem to work again! Thanks for the quick fix.
Deploying production again now.

Works again on my side as well.

Seems good now. Thank you :bowing_man:t2:

Thank you for the updates and letting us know it’s working for you again.

If you’re coming to this thread later, we’ve updated our status page (Netlify Status - Increase in errors in deployed sites) to Resolved . If you’re still having problems, please try re-deploying by going to the Deploy logs page, clicking on Trigger deploy and then selecting Clear cache and deploy site .

Please let us know if you continue to have issues.

1 Like

It’s working now ! Thank you

Thanks for confirming!