Plugin "@netlify/plugin-functions-install-core" internal error

Enabling the ‘Build Plugins Beta’ causes my project to fail.

Here’s my netlify.toml:

  for = "/*"
    Access-Control-Allow-Origin = "*"

  functions = "functions"

  package = "netlify-plugin-gatsby-cache"

  functions = "functions"

  from = "/api/*"
  to = "/.netlify/functions/:splat"
  status = 200

I tried adding: package = “@netlify/plugin-functions-install-core” to the toml file, but that plugin doesn’t exist.

any ideas or help?


Hi @luchoster,

Thanks for reporting this issue.
Could you please share a link to the deploy that failed?

I just enabled the builds plugin without any plugins defined in the toml file

Hey @luchoster,

Can you check out this topic and let me know if it helps clarify things? Cheers!

1 Like

It seems that adding the functions dependencies to the main package.json, fixed it for me.

Hi all,

We have just fixed this issue. This should now worked, even without modifying your netlify.toml nor package.json. Please let us know if this does not. Thanks!

Thanks, everything seems to be working fine now.