Not able to build my nodejs app

I’m not able to deploy my nodejs app. I’ve also tried build command as CI= npm run build, but still no results.
Pls tell me whether there is a problem with the code ?
Here is the link to my github repo:

Here are the deployment logs:

Hi @gandhikrish1806,

Thanks for reaching out! Could you clarify which site you’re seeing this issue on as the site in the screenshot no longer appears to be available. If you could provide the site name or a link to the site we can view the full deploy log. Thanks!

Hi @Melvin ,
Actually, I deleted the website mentioned in the screenshot.
I’ve tried deploying it again and I’m facing the same issue, so pls have a look at this new deploy. I’m attaching a screnshot.

Hey @Melvin,
Have you checked the issue?

Netlify is not meant to run Node.js servers: [Support Guide] Can I run a web server, HTTP listener, and/or database at Netlify?. With that being said, you’re yourself sending process.exit(1) which is causing the build to fail:

This is a code issue, not a Netlify problem. Here’s your deploy log: Deploy details | Deploys | jade-cactus-2ebf36 | Netlify

1 Like

Thanks @hrishikesh for the help