Netlify is not detecting my form

Netlify is not detecting my form, and I have no idea why. I’ve followed all debug steps
When hugo generates my page code, the form html is:

<h1 id=title>Join Form</h1>
<form name=join netlify-honeypot=secret-field data-netlify=true action= id=apply>
    <p class=invis>
        <label for=secret-field>Don’t fill this out if you're human: </label>
        <input name=secret-field type=text>
        <label for=name class=required>Your Name: </label>
        <input type=name name=name required autocomplete=name>
        <label for=email class=required>Your Email (or one we can message you by): </label>
        <input type=email name=email autocomplete=email required>
        <label for=school class=required>Your School/College: </label>
        <input type=text name=school required>
        <label for=school-year class=required>Your School Year: </label>
        <select aria-label="School Year" name=school-year required>
            <option>Please select…</option>
            <option value=6>6</option>
            <option value=7>7</option>
            <option value=8>8</option>
            <option value=9>9</option>
            <option value=10>10</option>
            <option value=11>11</option>
            <option value=12>12</option>
            <option value=13>13</option>
        <label for=why class=required>Why you would like to join the Youth Council: </label>
        <textarea name=why required></textarea>
        <label for=how class=required>How your skills or interests would help the work of the Youth Council: </label>
        <textarea name=how required></textarea>
        <button type=submit class="button cta">Send</button>
    <p><span style=color:red>*</span> Required</p>

I don’t quite get what’s wrong.

I’ve tried a bunch of things, including renaming the form - nothin makes the form work. When the html is deploid, the data-netlify is not removed and the hidden input is not added.

Have you checked out our form debugging guide here?

Your issue is almost certainly in there. Your form as quoted looks fine, so if you have confirmed that you’re doing all those things, a link to the html file that has that form code in it would be our next step for helping out.

I can confirm I have followed all steps.
The live site is at

@fool Removing the custon action solved the issue. This seems a bit wierd, and I would like to keep my custom thank you page.

Hello @JoelEllis,

Glad to hear you got things working. As far as the ‘action’ attribute goes, have you tried using the value “/join-thanks” without the trailing slash and see if that makes things work?