Netlify Forms not working with Gatsby site after deploying to separate account?

Hey all,

I am building a website for a client and I initially hosted it on a netlify link on my account linked to my github. My client then wanted to create his own github and netlify so he could have access to the files.

However, my Netlify forms are now no longer working on the new account. Is this because Netlify read it during the build process on my account and now doesn’t recognize it on the client’s? I have tried renaming the form but it still is not appearing within the Netlify forms tab on the client’s account. I have since deleted the website on my account.

Please let me know if there are any solutions! I am relatively new to Gatsby and Netlify. Thanks for your time in regards to this post!

Hi, @wchesh24. We have a forms troubleshooting guide here:

If that guide doesn’t help, would you please send use the information below?

  1. The URL for your live form as you want visitors to use it
  2. The URL of your deployed html form (in case you have a javascript form, we need to literally be linked to the html version you’ve deployed as mentioned above - look for “pure javascript”)
  3. The form name that you’ve set and that shows in our UI
  4. Any errors or logs from the Netlify build logs, dashboard or browser developer console
  5. Description of anything you have tried that did or didn’t help or make things better/worse