Looks like you've followed a broken link or entered a URL that doesn't exist on this site


I don’t understand my mistake, although I consulted the forum, I’m a beginner in computer science, I give you all the screenshots.



thanks you

Hi there, did you give this a read through already?

Hi Team,
I have the same error, when deploying the app from github. I am pointing at the “dist” folder during the build process. The site is published successfully, when I go to the link, at first the site is displayed, later the 404 error occurs, the URL points to the public/index.html even though I pointed it to the dist folder… Could you help?

Here is my log:
9:00:41 PM: Build ready to start
9:01:16 PM: build-image version: 9cade8af58c2cf3a17a1e9433d2e979149488837
9:01:16 PM: build-image tag: v3.3.5
9:01:16 PM: buildbot version: eb060c4dc3a8a73f9004f460f04632708166ca51
9:01:16 PM: Fetching cached dependencies
9:01:17 PM: Failed to fetch cache, continuing with build
9:01:17 PM: Starting to prepare the repo for build
9:01:17 PM: No cached dependencies found. Cloning fresh repo
9:01:17 PM: git clone https://github.com/michalbrk/chucknorrisjokesapp
9:01:17 PM: Preparing Git Reference refs/heads/master
9:01:18 PM: Starting build script
9:01:18 PM: Installing dependencies
9:01:20 PM: v10.17.0 is already installed.
9:01:21 PM: Now using node v10.17.0 (npm v6.11.3)
9:01:21 PM: Attempting ruby version 2.6.2, read from environment
9:01:23 PM: Using ruby version 2.6.2
9:01:23 PM: Using PHP version 5.6
9:01:23 PM: Started restoring cached node modules
9:01:23 PM: Finished restoring cached node modules
9:01:24 PM: Installing NPM modules using NPM version 6.11.3
9:01:46 PM: > yorkie@2.0.0 install /opt/build/repo/node_modules/yorkie
9:01:46 PM: > node bin/install.js
9:01:46 PM: setting up Git hooks
9:01:46 PM: done
9:01:46 PM: > node-sass@4.13.0 install /opt/build/repo/node_modules/node-sass
9:01:46 PM: > node scripts/install.js
9:01:47 PM: Downloading binary from https://github.com/sass/node-sass/releases/download/v4.13.0/linux-x64-64_binding.node
9:01:47 PM: Download complete
9:01:47 PM: Binary saved to /opt/build/repo/node_modules/node-sass/vendor/linux-x64-64/binding.node
9:01:47 PM: Caching binary to /opt/buildhome/.npm/node-sass/4.13.0/linux-x64-64_binding.node
9:01:47 PM: > core-js@3.4.0 postinstall /opt/build/repo/node_modules/core-js
9:01:47 PM: > node postinstall || echo “ignore”
9:01:48 PM: > core-js-pure@3.4.0 postinstall /opt/build/repo/node_modules/core-js-pure
9:01:48 PM: > node postinstall || echo “ignore”
9:01:48 PM: > node-sass@4.13.0 postinstall /opt/build/repo/node_modules/node-sass
9:01:48 PM: > node scripts/build.js
9:01:48 PM: Binary found at /opt/build/repo/node_modules/node-sass/vendor/linux-x64-64/binding.node
9:01:48 PM: Testing binary
9:01:48 PM: Binary is fine
9:01:50 PM: npm
9:01:50 PM: WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/fsevents):
9:01:50 PM: npm WARN
9:01:50 PM: notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})
9:01:50 PM: added 1283 packages from 878 contributors and audited 24960 packages in 25.229s
9:01:50 PM: found 0 vulnerabilities
9:01:50 PM: NPM modules installed
9:01:50 PM: Started restoring cached go cache
9:01:50 PM: Finished restoring cached go cache
9:01:50 PM: unset GOOS;
9:01:50 PM: unset GOARCH;
9:01:50 PM: export GOROOT=’/opt/buildhome/.gimme/versions/go1.12.linux.amd64’;
9:01:50 PM: export PATH="/opt/buildhome/.gimme/versions/go1.12.linux.amd64/bin:${PATH}";
9:01:50 PM: go version >&2;
9:01:50 PM: export GIMME_ENV=’/opt/buildhome/.gimme/env/go1.12.linux.amd64.env’;
9:01:50 PM: go version go1.12 linux/amd64
9:01:50 PM: Installing missing commands
9:01:50 PM: Verify run directory
9:01:50 PM: Executing user command: npm run build
9:01:51 PM: > chnorrisjokesapp@0.1.0 build /opt/build/repo
9:01:51 PM: > vue-cli-service build
9:01:52 PM: - Building for production…
9:02:01 PM: DONE Compiled successfully in 8901ms8:02:01 PM
9:02:01 PM: File Size Gzipped
9:02:01 PM: dist/js/chunk-vendors.af89a92e.js 111.05 KiB 39.21 KiB
9:02:01 PM: dist/js/app.3c757737.js 3.66 KiB 1.65 KiB
9:02:01 PM: dist/css/app.0b7192ad.css 3.75 KiB 1.10 KiB
9:02:01 PM: Images and other types of assets omitted.
9:02:01 PM: DONE Build complete. The dist directory is ready to be deployed.
9:02:01 PM: INFO Check out deployment instructions at https://cli.vuejs.org/guide/deployment.html
9:02:02 PM: Skipping functions preparation step: no functions directory set
9:02:02 PM: Caching artifacts
9:02:02 PM: Started saving node modules
9:02:02 PM: Finished saving node modules
9:02:02 PM: Started saving pip cache
9:02:02 PM: Finished saving pip cache
9:02:02 PM: Started saving emacs cask dependencies
9:02:03 PM: Finished saving emacs cask dependencies
9:02:03 PM: Started saving maven dependencies
9:02:03 PM: Finished saving maven dependencies
9:02:03 PM: Started saving boot dependencies
9:02:03 PM: Finished saving boot dependencies
9:02:03 PM: Started saving go dependencies
9:02:03 PM: Finished saving go dependencies
9:02:05 PM: Build script success
9:02:05 PM: Starting to deploy site from ‘dist’
9:02:05 PM: Creating deploy tree
9:02:05 PM: 3 new files to upload
9:02:05 PM: 0 new functions to upload
9:02:05 PM: Starting post processing
9:02:06 PM: Post processing done
9:02:06 PM: Site is live
9:02:22 PM: Finished processing build request in 1m6.039434706s

Could you give us a URL that you are seeing 404 so we can look in our internal logs to try to understand what is happening? Would also be useful to get an x-nf-request-id HTTP header value for the failing request as described here: [Common Issue] Netlify Support asked for the 'x-nf-request-id' header? Why are they asking for it and how do I find it?

Hi Chris,
thanks for getting back to me. I’ve managed to fix it myself, it occured that there was an error causing this originating from my build in the Vue app itself, therefore I had to threw away everything and build it from scratch and now it works. I guess topic closed then. :slightly_smiling_face:

Best Regards,


czw., 5 gru 2019, 01:43 użytkownik Chris fool McCraw via Netlify Community netlify@discoursemail.com napisał:


Please I had the same issues with my Site…www.ayoadeshoecare.com.ng
Looks like you’ve followed a broken link or entered a URL that doesn’t exist on this site.
“” Please how can I solve it?"

hi there, we are responding here so we are closing this thread.

1 Like