Identity-signup function not being triggered when verification link used - 422

Hello Support team,
I am experiencing an issue where users can’t confirm/verify their account through a link.

It was all working until yesterday (it seems) - today at 4:38 AM I am seeing first user that didn’t confirm.
The last build happened on Nov 14 at 7:38 PM.

When I test this, and get a verification email link, upon visiting it throws an error
{“code”:422,“msg”:“Failed to handle signup webhook”}

and when added a debug code in identity-signup.js just to see if it gets triggered, it does not.

Netlify site name:

In the build from Nov 14th it shows it is aware of the identity-signup.js
7:40:54 PM: Packaging Functions from functions directory:
7:40:54 PM: - identity-signup.js

Any help is appreciated, or pointers, as this was working just fine and I didn’t do any deploy.

Happy to provide more details.
Thank you.

Nothing changed and it started to work. Users are able to verify themselves.

I would still love to know what might have been the issue please.

Nothing in the status suggests that there was any issue with identity.

Thank you.

Hey there, @Sotak :wave:

Thanks so much for reaching out! I shared this with the Support Team, and we don’t see a specific issue that would have caused this to stop. That being said, if this comes up again please let us know! Additional context around what the function is doing, the function file, etc. would all be beneficial.

Again, I am glad you are no longer encountering this obstacle!

Hi Hillary,
The function wasn’t even triggered, I have spent a fair amount of time trying to debug it, but all the other systems triggered in that function worked just fine. I even tried an empty function with just console.log. It did not work.

It kind of worries me, I didn’t do anything on my end, no updates at all, it stopped, then it resumed working again. Six people were affected by not being able to verify their emails and sign up for the trial during ~24 hours.

Thanks anyway.

I checked our logs and we saw the following:

I can see that for each of the triggered webhooks, we tried thrice before resulting in a failed response.

Each of those 3 attempts threw a 403 error - which we don’t know why. 403s are usually returned if you try to access those event-driven functions directly.

Do you have a specific timeframe that we can look at? At the moment, I’m not about to figure out which one os these are actually related to the errors you saw and which are not.

Thank you Hrishikesh,
I am seeing first registration that has not been verified at 4:38 AM (16 hours ago)
and the first when it started working was at 2:56 PM (6 hours ago) it seems.

I tested on my own at 11:09 AM (9 hours ago) and 11:24 AM (9 hours ago) - this is when clicking the verification link didn’t work.

Thank you.

Hey @Sotak,

Thanks for that. Could we also ask what timezone are those timings in?

This is a CET timezone.

Hi @Sotak,

I did some more checks, but the “cause” of this remains unknown. I can see that the request was received, and the response of a failure was sent, but as to why it failed in the first place, there’s no information.

Did this only happen with event functions, or did you also see this happen with any other functions that you were probably using?

In any case, at a bare minimum, the function should have logged the basic statements, and seeing that we can see the request on our end, I’d “assume” that it executed.

Thank you,
I did want to debug this and have been testing this by adding a console log in the function at the very first line, but it did not get triggered (this was when it wasn’t working). I believe the other functionality like login worked well, but the identity-signup when the user wanted to verify themselves did not.

I have been changing the code on the dev build, left the production intact.

Unfortunately, at this stage it looks like there’s little to nothing that we can do. Our logs claim the function was invoked (but these could have been some other invocations), but nothing got logged in the function console; there was an error 422 thrown. In most common cases, it happens because the function fails, but here it was simply not invoked.

I know this is not something you were wanting to read and we’d also love to get to the bottom of this, but the current available information is just not enough to make any valid conclusion. I hope this doesn’t happen again, but in case it does, it would be very helpful if you could share the x-nf-request-id response headers and maybe the HAR file recordings.

Hi Hrishikesh,
understand and thank you for looking into this.

If this happens again I will try to get more details, fingers crossed it won’t. :slight_smile:

Thank you

We had the exact same issue, that same day, seemed to be resolved without doing major changes from our side.


Thanks for letting us know, @fabianhijlkema :netliconfetti:

I am seing this on my end along side many others

  1. /api/* /.netlify/functions/:splat 200 this is not working for my site
  2. When I initiate a sign up, my web hooks do not get triggered
  3. when I try to invite someone to my site I see this
    `{“code”:422,“msg”:“Failed to handle signup webhook”}

I had changed my netlify default domain to a custom one yesterday. I am not sure if this issue is related to [Support Guide] Why do DNS / SSL changes take up to 48 hours to propagate?

I have been experiencing so many issues ever since I changed to a sub domain as a primary.

Hey @aoloo,

Do we have a site name to check?

EDIT: Please continue in your own thread here: