Files not appearing in Large Media Tab

Files are successfully added to LFS and the image files on Github are replaced with pointer files, but files are not uploaded to Netlify Large Media Tab and images aren’t displayed in build.

Hi, @Joelforr. There is an initial troubleshoot process outline here:

Have you tried the steps in that guide? If not, would you please see if that guide helps?

If that guide doesn’t solve the issue, what is being shown by the following two commands?

git lfs track
git lfs ls-files

Also, are the real versions of the files in the local git repo or do those files in the repo contain their pointer text instead?

I have tried the steps in the guide to no success. The files in the repo contain their pointer text and the result of the two commands are as follows:

PS D:\Users\Joel\Documents\Github Database\WebDev Repos\v3> git lfs track
Listing tracked patterns
test-img.png (.gitattributes)
Listing excluded patterns
PS D:\Users\Joel\Documents\Github Database\WebDev Repos\v3> git lfs ls-files
9f8fa56eda * src/assets/test-img.png
PS D:\Users\Joel\Documents\Github Database\WebDev Repos\v3>

Hi, @Joelforr, I will keep you updated as we work on this.

@Joelforr, we’re still working on this in a private channel. We do hope to have this resolved (or at least have next steps) tomorrow. More soon.

I’m having the same issue, any updates?

Hi, @robert.andrade. The issue turned out to be that the files were being processed at build time by the static site generator.

This is incompatible with Netlify Large Media (NLM) as documented here, quoting:

Files tracked with Large Media are uploaded directly to the Netlify Large Media storage service on push, completely bypassing the site build. This saves build time, but also means that the files are not available to tools that process asset files during the build, such as Hugo’s image processing or the gatsby-image plugin. Depending on your needs, you may be able to replace this functionality with Netlify’s image transformation service.

Are your files being copied to the publish directory? Do the files stored in Git LFS require processing during the build process?

Would create-react-app do this? The images are being moved to the build folder but there’s no additional processing being done

1 Like

I checked the site I believe is having this issue. When I check the file in question, I get the Git LFS pointer, not the file itself.

Are you sure the actual file is present in the local repo? If so, would you please pushing all the files to LFS again using the command below (adjusting the branch name is needed if you are not using “master”):

git lfs push --all origin master

After this is done, please try deploying the site again. (A new deploy will be required for any changes to take effect.)

If this doesn’t resolve the issue, let us know here and we’ll keep troubleshooting.

Thanks for your continued responses. I did the command and the files are still not showing up in the large media tab. To be clear, the .svg files are there, it’s the .jpg files that are not appearing. I sent my public repo to the netlify support team through email if that helps

I’m updating this topic to note that work continues in the support ticket.