Home
Support Forums

Error publishing post in CMS

Trying to publish a new entry as we do each week and this week we’re encountering an error stating that the branch cannot be merged. Attempted deleting the article and starting from scratch but still encountering the same error.

Hi there, @amy :wave:

Are you using github to merge your branches? If so, I recommend you keep an eye on their status page which is outlining an ongoing incident.

If you are not using github, can you please share your Netlify site name?

We are using GitLab instead.
Netlify site name is confident-leakey-41cf06.

Hey there @amy

Could you please point us to your GitLab repo. I’ll have a look at that whilst @hillary can check out if there might be something going wrong on Netlify’s side… it seems pretty weird that this issue just appeared out of nowhere without any edits to the CMS config, is that right?

Kyle.

Our repo is private and not public. Is there something specific that you would like us to look into? But yes, you are correct… there have been no edits to the CMS config.

It would be anything under the admin directory. Typically I would be looking for:

  • Go back to default index.html from Netlify CMS quickstart

  • Checking config in yml - correct git branch set up… check for any extras that could be causing the issue.

That’s a quick run down of what I would go through… could you tell us what you have done to debug the issue. We want to get anything that could be going wrong locally fixed before looking at the Netlify side of things.

Kyle.

1 Like

You’ll have to excuse me as I’m not much of an experienced developer so I do struggle.

Our confiig.yml and index.html files have not had any changes in over a year. This is a process we’ve been using for almost two years without issue. The inability to publish an entry in Netlify CMS only started within the last week.

As for what I have tried… I’ve deleted the post in Netlify CMS and recreated it. I have tried changing the slug to the article I’m trying to publish. I tried publishing a second entirely different post in the meantime. All show the same problem. Unfortunately, the error message isn’t giving me much to go on.

Don’t worry about it… if at any point you don’t get something then just say and I’ll explain it better aha.

I’ve had a look through the common error messages with Netlify-CMS and I can’t find an issue related to the one you are experiencing. I understand that your repo is private. If you could somehow give me access to it I will be able to reproduce and find where somethings going wrong.

My GitLab account is kylesloper

Thank you! We’ve given you developer access to our repo through the 13th. If need be we can extend the date. You should get an invite via email I assume. If not, let me know. Any help or leads you can provide is extremely appreciated as we’re both baffled.

1 Like

Hi there @amy,

thanks for confirming! I understand from the above responses that your repo is private. Is it possible for you to create a reproduction repo? This will allow our support team to look into this further.

1 Like

We have granted kylesloper temporary access to the repo. If there are other support members that can help, we can grant that.

Hey there, @amy :wave:

Understood! I’ve spoken with some folks internally about this, and they suggest merging the PR directly on GitLab to see if that resolves it. This usually works for merge conflicts!

Let me know if this works!

1 Like

Unfortunately not working… Hoped to give that a shot but I am unable to merge the branch. Just see a spinning circle and the merge button never allows me to click on it.

Hi there Amy, I’ve cloned the repo and at the moment I can’t see any syntax issues that could be causing the problem.

I’m going to redeploy the repo later today on a password protected site to re-do the git configuration.

Hang in there… the support team or I will find a solution soon :grinning:

1 Like

Sounds great. Appreciate all the help more than you can know. :grinning_face_with_smiling_eyes:

1 Like

Hi :wave:

Since it’s not possible to merge the PR directly on GitLab, this seems like a GitLab issue.

@Amy do you mind trying to contact GitLab support to see if they can share more information on this issue?

1 Like

I will reach out to GitLab support. In the meantime, is there anything further that can be explained as to what the error (“Branch cannot be merged”) that PUT request is providing? Is that indicating a merge conflict or something else? Having this information will help us to debug further as we are still experiencing problems and this has caused a block for us and we have already missed one deployment Thursday and have yet another scheduled for this Thursday.

Hey there @amy. Sorry work has been super busy recently I have cloned your repo and I’m in the process of creating a new repo with GitHub. I understand that the site has upload dates for your visitors so I will endeavour to get the CMS integration working as fast as possible.

May I ask. If this is an issue with GitLab itself, are you open to switching to GitHub either temporarily or permanently at your discretion. I’m just thinking it terms of getting the blog up as soon as and if that may require a service change for now.

Could I also ask for a renewed repo access if that’s okay with you

Hope you are well.

Our traffic isn’t exceedingly high right now so thankfully we have time to get posts up. As for switching to GitHub and continued access, I will have to discuss this with my husband as he set up the project & I’m maintaining it at the moment. I know his time is very limited right now unfortunately.

1 Like

Just an update. My husband and I were playing around and debugging and had an observation. We had two branches in gitlab that were stuck in a “checking if branch can be merged” state. The thing these two branches had in common is that we tried to publish them via the editorial workflow. We closed those two branches in gitlab. we then created a new entry in netlify CMS. Rather than click publish to merge in the workflow, we manually merged the branch in gitlab and deployed. all is good. however, that to me suggests that the act of cllicking the publish button is causing an issue somehow. so our current crisis is averted, but unsure if the issue is fixed, but we have a workaround.

1 Like