Css not woking with django project

Hello, everyone
I am trying to host my Django app but my CSS is not working it only has text.
I tried removing my base.css and base.html to the same path as my index.html but no luck. I tried a few tutorials but I found none on this issue with Django, can someone please help me?


5:44:39 PM: build-image version: 4c0c1cadee6a31c9bb8d824514030009c4c05c6a (focal)
5:44:39 PM: build-image tag: v4.15.0
5:44:39 PM: buildbot version: e6d57a43d406fdcaf8ee2df93f280acce2e07259
5:44:40 PM: Fetching cached dependencies
5:44:40 PM: Starting to download cache of 30.0MB
5:44:40 PM: Finished downloading cache in 239.321438ms
5:44:40 PM: Starting to extract cache
5:44:40 PM: Finished extracting cache in 193.661242ms
5:44:40 PM: Finished fetching cache in 477.235199ms
5:44:40 PM: Starting to prepare the repo for build
5:44:40 PM: Preparing Git Reference refs/heads/main
5:44:41 PM: Parsing package.json dependencies
5:44:42 PM: Section completed: initializing
5:44:42 PM: No build steps found, continuing to publishing
5:44:42 PM: Starting to deploy site from ‘’
5:44:42 PM: Creating deploy tree asynchronously
5:44:42 PM: Creating deploy upload records
5:44:45 PM: 1 new files to upload
5:44:45 PM: 0 new functions to upload
5:44:45 PM: Starting post processing
5:44:45 PM: Post processing - HTML
5:44:45 PM: Post processing - header rules
5:44:45 PM: Post processing - redirect rules
5:44:45 PM: Section completed: deploying
5:44:45 PM: Section completed: building
5:44:45 PM: Post processing done
5:44:45 PM: Section completed: postprocessing
5:44:46 PM: Uploading Cache of size 29.9MB
5:44:46 PM: Section completed: cleanup
5:44:46 PM: Finished processing build request in 6.56585295s
5:44:48 PM: Site is live :sparkles:
PLEASE help us help you by writing a good post!

Hi @derrellj a git repo to reference would be helpful to investigate further :slightly_smiling_face:

Hi @kylesloper ,
here are links to the git repo

gh repo clone derrellj/under-construction



Thanks. And just to clarify, the CSS is working locally just not after deployment? Can you please screenshot your build settings found in the Netlify UI.

Curious if this is related

1 Like

@kylesloper, the repository @derrellj shared is a Django project.
It seems @derrellj created two different posts relating to the same problem.

Didn’t notice that thanks @clarnx :netliheart:. @derrellj for future reference please do not open more than one topic on the same issue so that we can avoid redundant and time-wasting threads like this :slight_smile:

1 Like