Home
Support Forums

Cant push after trying to setup large media

Hi everyone!
I am trying to setup Large Media on my Manjaro Linux desktop without success. My website is grupoibiracu.netlify.app.

I can’t git push anymore (git log: credential-netlify' is not a git command.)

netlify lm:setup returns an error after browser authorization:
TypeError: Cannot read property 'slug' of undefined

I am seeing this exact same issue. I can’t pull files down from netlify large file storage.

Hi, @grupoibiracu and @furiouskj. We have a troubleshooting support guide for Large Media here:

If that guide doesn’t help please send us the following information:

  • the output of netlify lm:info
  • the output of git config -l

In your case, @grupoibiracu, you are not being logged in. First we need to get the following command working:

netlify login

If the login is successful, netlify status should show something like this:

$ netlify status
──────────────────────┐
 Current Netlify User │
──────────────────────┘
Name:  Luke Lawson
Email: something@example.com
Teams:
  mu: Collaborator

We will need to resolve that before we can troubleshoot Large Media as you need a working Netlify CLI login to install the Large Media Git credential helper. You cannot push to Large Media without the Git credential helper and you cannot install the Git credential helper until you can login with Netlify CLI.

​Please let us know if there are any questions and we look forward to getting additional information to troubleshoot.

Hi @luke,

netlify status returns that I am already logged in.

netlify lm:info returns:

  ✔ Checking Git version [2.29.2]
  ✔ Checking Git LFS version [2.13.2]
  ✔ Checking Git LFS filters
  ✔ Checking Netlify's Git Credentials version [0.1.9]

git config -l returns

user.email=fe*****@gmail.com
user.name=J***5
credential.helper=cache --timeout 3600
filter.lfs.required=true
filter.lfs.clean=git-lfs clean -- %f
filter.lfs.smudge=git-lfs smudge -- %f
filter.lfs.process=git-lfs filter-process
include.path=/home/felipe/.netlify/helper/git-config
credential.helper=
credential.helper=netlify
core.repositoryformatversion=0
core.filemode=true
core.bare=false
core.logallrefupdates=true
remote.origin.url=https://gitlab.com/grupoibiracu/ibirasite.git
remote.origin.fetch=+refs/heads/*:refs/remotes/origin/*
branch.master.remote=origin
branch.master.merge=refs/heads/master
gitg.mainline=refs/heads/master
atomgithub.historysha=4******0
lfs.https://gitlab.com/grupoibiracu/ibirasite.git/info/lfs.access=basic

I was logged in and have the latest versions of Git, LFS and Git Credentials.

The slug issue still happened.

I actually found another issue and fixed it. The lm plugin was looking for ~/.netlify/config.json which is never created on mac. There is one created in ~/Library/Preferences/netlify/… so I just copied that to the config.json path the git-credential tool was looking for.

Still the tool seems broken for fresh installs in mac using either homebrew or npm

1 Like

Hi, @grupoibiracu. I think I found the issue with the site you wrote in about. The Large Media add-on is not configured at Netlify for this site. The solution for this would normally work like this:

To summary those steps, you will run the following commands:

netlify link
netlify lm:setup
git add .lfsconfig
git commit -m 'install Large Media add-on at Netlify'
git push

After this occurs, the Large Media add-on will be added to the site and Netlify will become the host for the Git LFS files in the repo. This will allow the git push to succeed.

Hi, @furiouskj. To troubleshoot I still need the information requested previously above:

Would you please include that information here so we can assist with this issue?

I don’t have a .lfsconfig file. When I follow the steps for setup, I get TypeError: Cannot read propery 'slug' of undefined on netlify lm:setup after clicking authorize on the browser.

1 Like

Having the same issue as well.

CLI logged in and site linked.

Netlify Status & Netlify lm:info
both returned normal.

Followed the Doc on Large Media Setup again.
Netlify lm:setup
Returns the following after clicking “Authorise” in the browser:
TypeError: Cannot read property 'slug' of undefined

No .lfsconfig generated.

git config -l results:
credential.helper=osxkeychain filter.lfs.clean=git-lfs clean -- %f filter.lfs.smudge=git-lfs smudge -- %f filter.lfs.process=git-lfs filter-process filter.lfs.required=true user.name=L**** W*** user.email=************@gmail.com include.path=/Users/l*******g/.netlify/helper/git-config credential.helper= credential.helper=netlify credential.helper=osxkeychain core.repositoryformatversion=0 core.filemode=true core.bare=false core.logallrefupdates=true core.ignorecase=true core.precomposeunicode=true remote.origin.url=https://github.com/lawrencedrums/lwrc.io.git remote.origin.fetch=+refs/heads/*:refs/remotes/origin/* lfs.https://github.com/lawrencedrums/lwrc.io.git/info/lfs.access=basic

Here it is:
:heavy_check_mark: Checking Git version [2.30.0]
:heavy_check_mark: Checking Git LFS version [2.13.2]
:heavy_check_mark: Checking Git LFS filters
:heavy_check_mark: Checking Netlify’s Git Credentials version [0.1.9]

This:

credential.helper=osxkeychain
filter.lfs.process=git-lfs filter-process
filter.lfs.required=true
filter.lfs.clean=git-lfs clean – %f
filter.lfs.smudge=git-lfs smudge – %f
user.name=Kenny Meyers
user.email=xxxxxxx
filter.lfs.clean=git-lfs clean – %f
filter.lfs.smudge=git-lfs smudge – %f
filter.lfs.process=git-lfs filter-process
filter.lfs.required=true
pull.rebase=false
include.path=/Users/kennymeyers/.netlify/helper/git-config
credential.helper=
credential.helper=netlify
credential.helper=osxkeychain
core.repositoryformatversion=0
core.filemode=true
core.bare=false
core.logallrefupdates=true
core.ignorecase=true
core.precomposeunicode=true
remote.origin.url=xxxx

Thank you for your tip, @furiouskj.

In my case, config.json did exist under ~/.netlify, but it was missing a bunch of fields that were present in ~/Library/Preferences/netlify/config.json. So I replaced the ~/netlify copy with the ~/Library/Preferences/ one, and re-ran netlify lm:setup. This time, the command ran successfully and created the .lfsconfig, finally.

2 Likes

Your solution also worked for me @alecazam! Thanks! In my case (linux), I’ve copied the config.json from ~/.config/netlify

2 Likes

Yeah the solution from @alecazam also seems to work for me, though

When we onboard new people to our project, it is always takes a couple of hours to set up our site on someone’s computer and usually involves a lot of inspecting of various .config files across multiple computers, and re-trying all of the various installs multiple times. Having to do this fix is new for us.

In general, it seems super frictionless to set up netlify-cli, but never ends up being the case with our project which uses LFS. It seems that there could be better checks in netlify-cli or the LFS set up to catch the situation above