Build fails: "Could not find 'bundler'"

We are experiencing the same issue as of today 22nd of Feb AEST on - any ETA for a fix?


Just also FYI - I migrated environment variables and still am getting same deploy errors. I don’t know where to go from here? I have looked at deployment guides, documentation - needs to be fixed on netlify platform it seems?

1 Like

I have the same error.

A quick hotfix solution:

  • Build your site locally (i.e. bundle exec jekyll build) and commit the static site directory (i.e. tar cvf site.tar.gz _site)
  • Update the deploy settings to tar xvf site.tar.gz
1 Like

check netlify bunlder version with yours. In my case, the project is bundler 1.16.3 and netlify is 2.1.4. As the message says, there is no bundler for that version. Try changing your bundler version to 2.1.4.

The bundler version doesn’t matter. Looking at my deploy logs …

12:34:17 PM: Using Ruby version 2.7.2
12:34:17 PM: Using Bundler version 2.3.8 from Gemfile.lock
12:34:18 PM: Successfully installed bundler-2.3.8
12:34:18 PM: 1 gem installed

then later on …

12:37:02 PM: $ bundle exec jekyll build
12:37:02 PM: Activating bundler (~> 2.3) failed:
12:37:02 PM: Could not find ‘bundler’ (2.3.8) required by your /opt/build/repo/Gemfile.lock.
12:37:02 PM: To update to the latest version installed on your system, run bundle update --bundler.
12:37:02 PM: To install the missing version, run gem install bundler:2.3.8
12:37:02 PM: Checked in ‘GEM_PATH=/opt/buildhome/.gem/ruby/2.7.0:/opt/buildhome/.rvm/rubies/ruby-2.7.2/lib/ruby/gems/2.7.0’, execute gem env for more information
12:37:02 PM: To install the version of bundler this project requires, run gem install bundler -v '~> 2.3'

So the build process installs 2.3.8 correctly then can’t find it … ie scripts not picking up paths correctly, or permissions not set correctly etc.

The ‘GEM_PATH’ in the script looks like it hasn’t added in whatever path is required for the 2.3.8 version. But who knows?

1 Like

Experiencing the same issue.

I have found a couple duplicate threads:

1 Like

Hey @netlify! Your product is on fire, please do something!


Same problem here.

I can’t see how it’s related to the environment variables migration. It just looks like Netlify isn’t installing the same bundler versions as before, which means lots of sites built on Ruby will fail to build (I have two Jekyll sites hosted on Netlify). It was a couple of days ago, so a notification would have been nice.

My error is:

7:09:14 AM: Activating bundler (~> 2.3) failed:
7:09:14 AM: Could not find 'bundler' (2.3.15) required by your /opt/build/repo/Gemfile.lock.
1 Like

I am having a similar issue with a React project and seeing unhelpful failure messages.
In the meantime, I could workaround this issue using netlify deploy --prod and manually deploy as explained here:

Also seeing the same issue with the site that was building fine until recently.

11:49:10 PM: Activating bundler (~> 2.4) failed:
11:49:10 PM: Could not find 'bundler' (2.4.7) required by your /opt/build/repo/Gemfile.lock.

but earlier in the log you can see

11:48:38 PM: Using bundler 2.4.7

I am experiencing the same issue on my site. My previous deploys had the same bundler I have now, I only made a minor change in the displayed text of some files, and all of a sudden, I got this error.

Given how many people are experiencing it, this is likely something on Netlify’s side. Has anyone from the Netlify support team already commented on this?

I have the same issue.

I noticed that the build version has changed from the last successful deploy to the failed one. Successful deploy is using @netlify/build 29.5.7 and failing one is using @netlify/build 29.5.8. The other big difference seems to be that Ruby is not pre-installed on the failing build, and there’s a long series of commands beginning with:

Required ruby-2.6.2 is not installed - installing.

Not sure if any of this is meaningful, just trying to get to the bottom of this!

I’m seeing a very similar issue here, with a site that worked 7 days ago:

12:28:33 PM: $ JEKYLL_ENV=production bundle exec jekyll build -d _site
12:28:33 PM: Activating bundler (~> 2.2) failed:
12:28:33 PM: Could not find 'bundler' (2.2.13) required by your /opt/build/repo/Gemfile.lock.
12:28:33 PM: To update to the latest version installed on your system, run `bundle update --bundler`.
12:28:33 PM: To install the missing version, run `gem install bundler:2.2.13`
12:28:34 PM: Failed during stage 'building site': Build script returned non-zero exit code: 2 (
12:28:33 PM: Checked in 'GEM_PATH=/opt/buildhome/.gem/ruby/2.7.0:/opt/buildhome/.rvm/rubies/ruby-2.7.1/lib/ruby/gems/2.7.0', execute `gem env` for more information
12:28:33 PM: To install the version of bundler this project requires, run `gem install bundler -v '~> 2.2'`
12:28:33 PM: ​
12:28:33 PM:   "build.command" failed                                        
12:28:33 PM: ────────────────────────────────────────────────────────────────
12:28:33 PM: ​
12:28:33 PM:   Error message
12:28:33 PM:   Command failed with exit code 42: JEKYLL_ENV=production bundle exec jekyll build -d _site (

I’ve tried explicitly adding bundler to the Gemfile and (it then got added to the lock-file too)

But the same error is printed out.

I noticed the Python version is 2.7 in the previous build and now states 3.8. I have Python 3.8 and Bundler version 2.2.13 on my own machine where I can build successfully.

Build image for working build: 5:59:05 PM: build-image version: 01daab3416c9da7032f1dcdb8b1adffdaf5ccb74 (focal)

Build image for broken and now blocked build: 12:25:23 PM: build-image version: c0621868af5001023389eeaa9dbfbbaf313f67e2 (focal)

Same issue here - with a site that last built successfully 2 days ago and now has very similar error logs to those above. The only difference in the site is the addition of a markdown file, no other major site changes. :melting_face:

I’ve managed to move off Netlify to GitHub Pages with actions. I realise that’s not for everyone.

I hope the netlify team will fix this, but if anyone else is being left in a bind like us, you can use my sample below:

1 Like

To anyone who is in crisis right now, don’t forget you can run the build locally and perform manual deployment using Netlify CLI. Not great for anyone with clients, but hey ho.

same here:
Could not find ‘bundler’ (2.3.19) required by your /opt/build/repo/Gemfile.lock.

1 Like

Hey all!

Could you please try building again? This might be related to a bad rollout which has now been reverted.

Apologies for the impact.


All good here. Thanks :slight_smile:


Build is OK now (without changing the source code/configuration).

Thanks Netlify for having fixed this quickly :slight_smile:

1 Like