Build failing today for gatsby site without descriptive error message

Hello, I tried deploying my gatsby site today, which was building fine till yesterday on Netlify and still builds fine locally.

But I’m getting the following error towards the end of my log, there is no other “descriptive message” above. Is it at all related to the other issues that netlify was facing today?

{ percent: 0.npm ERR! code ELIFECYCLE
5:16:17 PM: npm ERR! errno 1
5:16:17 PM: npm ERR! mprofit-website@0.2.0 build: gatsby build
5:16:17 PM: npm ERR! Exit status 1
5:16:17 PM: npm ERR!
5:16:17 PM: npm ERR! Failed at the mprofit-website@0.2.0 build script.
5:16:17 PM: npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
5:16:17 PM: npm ERR! A complete log of this run can be found in:
5:16:18 PM: npm ERR! /opt/buildhome/.npm/_logs/2019-11-19T11_45_21_489Z-debug.log
5:40:28 PM: Build exceeded maximum allowed runtime
5:40:34 PM: Execution timed out after 15m0s
5:40:34 PM: Error running command: Command did not finish within the time limit
5:40:34 PM: Failing build: Failed to build site
5:41:04 PM: Shutting down logging, 1 messages pending
5:41:04 PM: Failed to inform the API about a failed build, please retry the build or contact support

Hi, @ashin, and welcome to our Netlify community site.

Would you please send us a link to the deploy in the Netlify UI?

Without examining the site directly, my best guess is that the issue is similar the ones discussed here:

To summarize the topic above, often issues are caused some background process (making database or GraphQL queries for example) which isn’t exiting so the build never “ends” from the build systems point of view. This causes the build not to complete and it is therefore forcibly cancelled when the time limit is reached. The solution for this it to make certain any workers exit when their work is complete.

If this topic doesn’t help and/or there are other questions, please let us know.

Hi @luke,

Thanks for your reply!

Sure, here is a link to the deploy from yesterday:

I tried using the steps in the post you linked to identify and kill any running processes but without success. Also tried updating my dependencies, remove package-lock.json, clearing cache etc.

I’ve also tried redeploying a previously successful deploy on Netlify and am getting the same error.

Looking forward to any other insights you may be able to share to help me debug the issue.


Apologies, I was actually able to recreate the error locally after updating my dependencies.

Seems like there was a bug where few graphql ids were duplicated, and I guess gatsby did not catch them in their previous versions but maybe a recent minor version update which would have been downloaded by netlify caught it.

So it’s no issue with netlify. The only feedback I would have would be to somehow capture the error which was shown to me when building locally but could not see it on netlify so made it harder to debug:


There was an error in your GraphQL query:

- Unknown field 'allMarketingInfo' on type 'Query'. Source: document `downloadArchiveQuery` file: `GraphQL request`