Build error when linked to GitHub repo

Hello, I just started a site with manual deployment and this worked, but when I tried to link it to a GitHub repo and building from it it failed giving the following error

8:57:36 AM: Build ready to start
8:57:40 AM: build-image version: 8e315e54bc4032a32e73290be556cde4f8348c12
8:57:40 AM: build-image tag: v2.8.2
8:57:40 AM: buildbot version: 45cd00068410d70db72c9672cdd014995488e12a
8:57:40 AM: Fetching cached dependencies
8:57:40 AM: Starting to download cache of 254.9KB
8:57:40 AM: Finished downloading cache in 70.245286ms
8:57:40 AM: Starting to extract cache
8:57:40 AM: Failed to fetch cache, continuing with build
8:57:40 AM: Starting to prepare the repo for build
8:57:40 AM: No cached dependencies found. Cloning fresh repo
8:57:40 AM: git clone GitHub - maxgav13/geolonum: geolonum
8:57:45 AM: Preparing Git Reference refs/heads/master
8:57:45 AM: Starting build script
8:57:45 AM: Build command unable to start
8:57:45 AM: Error running command: fork/exec /usr/local/bin/build: no such file or directory
8:57:45 AM: Failing build: Failed to build site
8:57:45 AM: failed during stage ‘building site’: fork/exec /usr/local/bin/build: no such file or directory
8:57:46 AM: Finished processing build request in 6.005597136s

For context, this is an RMarkdown bookdown repo, I tried using “npm run build” for the building command


Hiya, sorry you are having trouble with your build.

This Common Issue contains a ton of useful debugging tips that can likely help you solve your problem :slight_smile:

We also recommend trying to search the forums with the build error you encountered - it’s likely your question was already asked by someone else!

If you are still having problems, please provide as much information as you can on what you have already tried, what your build settings are, your package.json, etc. Thanks!