Branch Deploys & Branch Subdomains on Custom Domain - nslookup fails "server can't find..."

Netlify instance name:
Custom domain:
We are using Netlify DNS and have branch deploys set to ‘ALL’

We also have branch subdomains configured

(Image upload rejected as I am new user)

We’ve read through everything we could find, including the common issues posts in this forum. We originally tinkered with setting branch deploys to individual branches, and then tried switched to ALL, but nothing seems to work.

The netlify domain works, however - ex.

We thought that a branch subdomain would show the above at

Help would be appreciated.

Hi, @ownhome, and welcome to our Netlify community site.

I’m showing the DNS service for is at AWS Route 53, not Netlify. The branch subdomain feature is automatic only for Netlify DNS. There is more documentation about this here:

The solution for this is documented there.

Note, the record is currently this:	60	IN	CNAME

However, it should be this:	60	IN	CNAME

(There should be no slash in the CNAME and the subdomain should be develop--ownhome not develop.ownhome.)

Please reply here when the required DNS record has been created and we’ll get the SSL certificate updated for this subdomain.

Also, because this DNS zone isn’t active with Netlify DNS, please delete the zone configuration at Netlify because having this configured while not active is known to cause other issues as well.

If there are any questions about this reply, we are happy to answer.

Hi Luke,

Apologies. I thought we had switched over to NetlifyDNS entirely. It seems like we only forwarded some entries.

We’re going to move entirely to NetlifyDNS first, and I suspect this will be resolved.

1 Like

Sounds good! Keep us posted!

Writing this down here for others in the future.

If using Amazon Route53, which is setup by default if you purchase your domain from AWS, you’ll need to delete the record set within Route53 first. Then, you’ll have to go into the “registered domains” link on the left side menu, and then enter the Netlify DNS nameserver’s.

Simply forwarding your nameservers to Netlify’s nameservers was the mistake we made. You can still get branched domains to work, but it won’t work automatically as described in some of the docs.

The Netlify DNS nameservers can be found at:

Dashboard → Domains → <your_domain> → Nameservers (scroll down)

Currently, the nameservers at the time of this post are listed below. However, this may change over time, so best check within your UI.

One more note: the list of name servers for your domain with Netlify DNS may differ from those above (or could be the same). Please consult the Netlify UI to be sure you have the correct list.

Hi had a similar problem, I was using branch subdomain (, but recently I decided to delete that branch and create another branch named minisitio (to test a sub-site into my main site), then I went to the Domain configuration and deleted the subdomain for trynfcms, then I added subdomain for minisitio branch, but the problem was that the url was not reachable.

Here my DNS records:

So, I decided to delete the new subdomain and create it again, 15 or 30 minutes later, the subdomain site was alive. Of course, I noticed that 3600 seconds of TTL is equal to 60 minutes, and maybe for that reason I was not able to see my site alive quickly.

This seems to be silly but maybe could help to somebody.