Home
Support Forums

Your connection to this site is not secure

Hello Netlify!
I’m glad I found a very easy and intuitive static page hosting.
After hosting my site and mapping a custom domain ran into issue with https. When i navigate to the site (custom domain name - https://www.smartograminnovation.com/ ) the certificate shows not secure and with message “Your connection to this site is not secure

  • site name. Example: stoic-keller-41b548
    Please find error snapshot
    error

Hi there! We’ve created this DNS Quickstart guide for this very purpose - to get you up and running as quickly as possible.

Please take a look - we have many resources listed at the bottom, too. And, there are tons of DNS questions you can access through our search! If your problem still persists after reading through all relevant guides, please post again and we will troubleshoot with you.

@knsatishkumar How long ago did you make these DNS entries? DNS can take up to 48 hours to propagate.

Hi, @knsatishkumar. The SSL certificate covered only the apex domain (smartograminnovation.com) but not the www subdomain (www.smartograminnovation.com).

This sometimes happens when domains are added. The solution is to click the “Renew certificate” button in the SSL settings for the site at Netlify. When I did so, the SSL certificate was extended to include www and the SSL is working now when I test.

If there are other questions or concerns, please let us know.

Thanks Luke, for Renewing the certificate! Yes I checked It works now! :smiley:
Thank you Greg & Perry for sharing helpful resources and attempt to resolve the issue.

1 Like