You don't have sufficient permissions

Hi, I deployed a gatsby site to

I added netlify cms plugins to gatsby.

when I try to login I receive “You don’t have sufficient permissions to access Netlify CMS”

I have disabled and re-enabled the git gateway and re-deployed

I’ve also tried entering my own personal access token, github says it still hasn’t been used

I’ve tried relinking the github repo and making it public

I’ve also made sure that the user I created in identity has the role of admin which is the same role setup in git gateway

I think I’m out of ideas and need help getting past the security to my admin page.

Let me know what I should try next

Hey @jacques,

I’m going to echo the response of my colleague, @erez , who suggests:

  1. Disabling/enabling git-gateway from Netlify site settings.
  2. Clearing browser cache (makes sure the CMS connects to the correct instance of git-gateway).
  3. Re-linking your site to the GitHub repo (and then disable/enable git-gateway ) from Netlify site settings.
  4. Creating your own token on GitHub manually and supply it to git-gateway via Netlify site settings.

I see that you have already tried some of these but there’s a couple of others to try :+1: