Wrong domain on first try with NetlifyCMS?

Let me in and I’ll never bother you again :slight_smile:

Am trying to create a blog on my site: freehold.buzz
I’ve already successfully deployed my static site to my subdomain: covid19.freehold.buzz using Netlify via Github.
Now I want to use NetlifyCMS.
Following this …
I added the required files to my Nuxt app
Enabled Identity Service
Registration is set to ‘invite only’
I enabled GitGateway

When I first accessed localhost:3000/admin it asked me to enter a domain name, then I got this message:
“Unable to access identity settings. When using git-gateway backend make sure to enable Identity service and Git Gateway.”

I may have entered the wrong URL on the initial setup. Should I have entered my target subdomain (covid19.freehold.buzz) or my Netlify URL:

How to I get out of this situation, please.
J Moore

I’m experiencing the same behavior, seems to me you caught a bug.
CC @erez

1 Like

Hi @ijimmoore, to clear the domain on localhost you can delete the local storage key netlifySiteURL.
If that doesn’t work with the correct domain, can you please share the network traffic while trying to login?

1 Like

I tried clearing the local storage key manually as I do quite often, but I get the same error regardless.

Can you share the browser traffic? There should be a request to get the identity settings, then another one to get git-gateway settings.

My Nuxt app now works great with NetlifyCMS, deployed with Netlify. Thanks!
An observation for others:

The doc I followed on provisioning my Nuxt app with NetlifyCMS omitted one step (inviting myself) which is not omitted in the NetlifyCMS generic doc:

Thanks for your help.
Good luck.
Stay safe.

1 Like