Wordpress blog not transferred properly, content pages display "page not found"

Hello, everyone.
We recently transferred a blog with multiple hundred posts to Netlify from Wordpress. Everything is great in terms of look and feel, however, only the first page of the blog (with the first 8 posts) seems to have been transferred. As soon as I click to page 2, I geT A “page not found” error.
I worked with a professional developer for this, but I am a marketer, so I’m not sure how to take it from here.

Any piece of advice would be much appreciated.
Thank you!

Hi @georgiana

The first thing I would suggest is getting in contact with the developer you worked with to have them address the issue.

If the developer is unable or unwilling to fix the issue, I suggest seeking the services of another developer.

Hi, and thanks for your reply. So this could actually be fixed. It does not have anything to do with the Wordpress plugin we used, does it?

If you are using a plugin to generate the pages that sounds like a good place to start. The developer is best placed to pin-point the cause and provide the solution.

Right. so basically, I’m currently either forced to work with an alternative developer OR purchase a paid Netlify plan, where I could get an actual solution to my problem.


The purchase of a Netlify Plan has nothing to do with it.

1 Like

Hi @georgiana :wave:

Sorry to hear you are encountering obstacles.

Did you see this guide yet? This is the best place to start for “Page Not Found” issues.

If you are still seeing issues after following the troubleshooting steps in there, please check out this Support Guide as well. It outlines all of our build and deploy resources and will get you on the right track :slight_smile:

If none of the above resources help, please write back with your site name and what steps you have tried and we can look into this further!