Home
Support Forums

Why is my site not updating changes after github pushes

Hey there, I have a site hosted on Netlify and when I go to make changes its not updating.

1.) git add .
2.) git commit -m “new commit”
3.) git push

  • 4.) can then see the updated files on github

After all of this no change to my Netlify site. What do I need to change?

Deployment Logs (I’ve tried auto deploying based on git pushes, deploying with cache cleared and none of them worked. This is the log associated to my last attempted deployment)

1:21:13 AM: Build ready to start
1:21:16 AM: build-image version: fd3b56fcdbaad56e70919e8a4b2da9b411ec3532 (xenial)
1:21:16 AM: build-image tag: v3.10.1
1:21:16 AM: buildbot version: 84197c5d0209353d9407aac932bd185d2d2eb582
1:21:16 AM: Fetching cached dependencies
1:21:16 AM: Starting to download cache of 140.9MB
1:21:17 AM: Finished downloading cache in 791.594667ms
1:21:17 AM: Starting to extract cache
1:21:18 AM: Finished extracting cache in 1.853772833s
1:21:19 AM: Finished fetching cache in 2.690273326s
1:21:19 AM: Starting to prepare the repo for build
1:21:19 AM: Preparing Git Reference refs/heads/master
1:21:21 AM: Parsing package.json dependencies
1:21:21 AM: No build steps found, continuing to publishing
1:21:21 AM: Starting to deploy site from 'public'
1:21:22 AM: Creating deploy tree 
1:21:22 AM: Creating deploy upload records
1:21:22 AM: 0 new files to upload
1:21:22 AM: 0 new functions to upload
1:21:22 AM: Starting post processing
1:21:22 AM: Post processing - HTML
1:21:23 AM: Post processing - header rules
1:21:23 AM: Post processing - redirect rules
1:21:23 AM: Post processing done
1:21:23 AM: Site is live ✨
1:21:32 AM: Finished processing build request in 16.045589158s

I’m positive this is an issue from Netlify’s side because of this previously posted thread
Why is my site not updating changes - #12 by ryan-neil and that when I start a server locally I get no problems and the website is up to date.

Please help!

This is clearly showing that no files changed during the build as compared to previous build. Since your repo is private, we can’t check that so there’s so real conclusion to make.

I’ve made the repo public now. It’s strange because I see the commit messages and history on the repo but netlify doesn’t seem to capture them?

You don’t have a build command set:

https://app.netlify.com/sites/hardcore-haibt-d27b56/settings/deploys#build-settings

The logs mentioned that: Netlify App

And you’ve committed the public folder to your repo (which you shouldn’t) and thus Netlify simply published that. It’s likely an older folder that you built locally.

Thank you, I relinked netlify to the current version of the github repository for this project and added the hugo build command as referenced in this article :