Home
Support Forums

White screen upon deployment

Hi there,

I have deployed the site locally and while it can also be deployed on Netlify, I have a white screen instead of the app. I’ve read many of the forums on the same issue, including setting up netlify.toml and running craco. Nothing seems to work.

I am a beginner developer working on a full stack app. Would really appreciate some experienced eyes to look at it and point me to the issues.

https://botdapp2.netlify.app/
GitHub - markvelous/botdapp2 (adapted from another project)

Welcome @markvelous

In DevTools I see

Uncaught Error: Alchemy URL protocol must be one of http, https, ws, or wss. Recieved: undefined

Have you set up your keys/secret in the Netlify UI? ie.

REACT_APP_PINATA_KEY = [secret]
REACT_APP_PINATA_SECRET = [secret]
REACT_APP_ALCHEMY_KEY = https://eth-rinkeby.alchemyapi.io/v2/[secret]

Thanks for looking into this. I have set up dotenv for the keys. It wasn’t a problem with other projects using the same dotenv setting – these were deployed quite successfully.

So I run your code locally (yarn start) and was also able to build and run it.

What are your build settings? Can you post a screenshot from Netlify UI? Example:

Here you go:

I’ve tried using yarn and react-script as well but same result

Here’s the log on successful deployment:

It would appear that no scripts were pushed to the index.html to generate the frontend.

This is what I did.

  1. Deleted the package-lock.json file from the repository as this can sometimes cause issues.
  2. Set environment variables in Netlify UI
  3. Set command to yarn build (as you have a yarn.lock file, you can use yarn.

You may need to Clear cache and deploy site also.
Screen Shot 2021-07-14 at 10.35.45 pm

Here it is: https://admiring-goldwasser-68a5a9.netlify.app

I’ll remove the repo and site when you have a successful build.

2 Likes

Brilliant! Deployed at https://botdapp2.netlify.app/
And I learnt something new. Thanks a million Coel!

2 Likes