Home
Support Forums

When trying to deploy a repo, the build doesn't work,

my netlify site name- https://practicewebsite1.netlify.app
github repo- GitHub - Avinier/practice_website1: My first website as a Front-end beginner.

$ parcel build index.html --no-minify
      🚨  /opt/build/repo/images/sprite.svg: Invalid Version: undefined

This is the first issue

"build.command" failed                                        
6:09:29 PM: ────────────────────────────────────────────────────────────────
6:09:29 PM: ​
6:09:29 PM:   Error message
6:09:29 PM:   Command failed with exit code 1: parcel build index.html --no-minify
6:09:29 PM: ​
6:09:29 PM:   Error location
6:09:29 PM:   In Build command from Netlify app:
6:09:29 PM:   parcel build index.html --no-minify
6:09:29 PM: ​
6:09:29 PM:   Resolved config
6:09:29 PM:   build:
6:09:29 PM:     command: parcel build index.html --no-minify
6:09:29 PM:     commandOrigin: ui
6:09:29 PM:     publish: /opt/build/repo/dist
6:09:29 PM:     publishOrigin: ui
6:09:29 PM:   functions:
6:09:29 PM:     '*': {}

These are the others. I know there is one more problem like this, but unlike that persons, I have declared all the variables correctly (all small cases used in folder names etc.)
Please solve this.

Hi @Avinier,

There’s a similar discussion here: https://github.com/parcel-bundler/parcel/issues/5943. It would be helpful to you if you can post there as by looking at that thread, it seems like you’re probably not the only one affected by this.

Actually, everything is working fine in Live Server and Parcel, but when I try to deploy it on Netlify, the problem arises, please help

I’m not sure what you’re doing, but it works fine. Here’s my build log: Netlify App, here’s the website: https://blissful-agnesi-0a505d.netlify.app and here’s the repo: GitHub - Hrishikesh-K/practice_website1-main.

Would you retry with a new website?

DONE! I changed the parcel-bundler version from 1.12.5 to 1.12.3. And remembered to push the repo on GitHub.
Thanks for the help @hrishikesh, that GitHub thread helped