What are valid values for codeGenerator in netlify graph

I am trying to build a site with eleventy and netlify graph.
Following instructions I have configured netlify.toml to

[graph]
  codeGenerator = "netlify-builtin:eleventy"

But nothing is building and the netlify graph browser doesn’t work either

Could you please share what instructions you’re referring to? I’m sorry, I’m unable to find any reference to that code snippet.

Also, Graph usually works without any configuration.

Could you share more about what you’ve tried, or what exactly led you to try that config, or what you wish to achieve, etc.?


I think he means this :point_up_2:. I am also having an issue where I add this to my toml in my local repo.

“No codegen is configured but we detected a create-react-app framework. Want to auto-configure codegen?”

We have added it to the toml but nothing happens and the error doesn’t go away

Thanks for the input @aaronm!

Sadly, I’ve absolutely no idea how you even got that screen or what that text means. I’ve looped this to our devs and will let you know as soon as we have more information.

Could you let us know your Netlify CLI version @aaronm?

I am running netlify-cli/11.5.1

this is currently the error I am getting, after connecting my session:

After clicking “auto-configure codegen”, this pops up:

so I add the line to my toml file in my local machine and re-run the session connection command. And error continues in a loop.

The thing that is not happening is that the functions are not auto-generating as an export function for me to use in my app. From what I’ve read these functions need to be created when you click the magic wand on the graph cloud sandbox but sadly the button remains unclickable and I believe it is because of that error described earlier.

@hrishikesh

@hrishikesh I am getting the same problems as @aaronm.
To be honest I could not get past the issue so I’ve stopped using netlify:graph for now.

Thanks for the info, we’ve passed that to the devs and will continue to relay any more info that we get.

Same issue here. I’m running Astro. I also tried changing netlify-builtin:astro to netlify-builtin:node, but that failed too.

Getting this error:

Warning: Failed to load Graph code generator, please make sure that "netlify-builtin:astro" either exists as a local file or is listed in your package.json under devDependencies, and can be 'require'd or 'import'ed.

Error [ERR_MODULE_NOT_FOUND]: Cannot find module '/Volumes/Evo/Sites/astro-spotify-matrix/node_modules/netlify-builtin:astro/index.js' imported from /Users/scottrod/.nvm/versions/node/v16.17.1/lib/node_modules/netlify-cli/src/lib/one-graph/cli-netlify-graph.cjs

Hey there, @djmtype :wave:

Can you share your full deploy log, a URL to your site, and your build settings? This will help us investigate further.

The problem is I can no longer get that far.

Around February 2022 Netlify Graph would generate a JS file with configuration for my project after selecting generate. It all worked great. I had API endpoints I could hit. But, now the generate button (magic wand) appears to be disabled. See screenshot above posted by @aaronm.
Therefore I can’t generate anything for production. Mind you, in development everything works as advertised via GraphiQL editor.
The auto-configure codegen for Astro appears to be unrecognizable.

What I would expect to happen – if the codegen is unrecognizable, it would default back to generating vanilla JS just like it used to.

I looked at the code for Netlify Graph package which appears to have a default setting but setting codeGenerator = "netlify-builtin:default" doesn’t appear to work either.

Essentially, I’m facing the same problem everyone here has posted about.

Hey @djmtype,

Sorry for this. This slipped through our radar. The devs were able to reproduce this problem back when this was reported, but I am not sure what happened after that. We’ve pinged them to ask about the status of this.

Thanks Hrishikesh,

It halted me using graph so if there is a fix it would be appreciated.

Regards, Andy

Thanks for your patience!

I believe I am reporting correctly (but Hrishikesh may correct me when he’s back at work tomorrow if I am wrong) that “codegen is only intended today to work with next.js and remix”, so it not working with other frameworks yet is expected.

@fool is there any update regarding this issue? I tried after several months, and still the generate button is disabled through the UI when running netlify graph:edit.

Here’s my entire log after running netlify dev.

❯ ntl dev --graph
◈ Netlify Dev ◈
◈ Ignored general context env var: LANG (defined in process)
◈ Setting up local development server
◈ Starting Netlify Dev with Astro

> @example/blog@0.0.1 dev
> astro dev

  🚀  astro  v1.9.2 started in 283ms
  
  ┃ Local    http://127.0.0.1:3000/
  ┃ Network  use --host to expose
  
✔ Waiting for framework port 3000. This can be configured using the 'targetPort' property in the netlify.toml
◈ Functions server is listening on 57663
10:46:29 AM [astro] update /.netlify/edge-functions-import-map.json
10:46:30 AM [astro] update /.netlify/state.json
 ›   Warning: Failed to load Graph code generator, please make sure that "netlify-builtin:astro" either exists as a local file or is listed in your package.json under devDependencies, and can be 'require'd or 'import'ed.

Error [ERR_MODULE_NOT_FOUND]: Cannot find module '/Volumes/Evo/Sites/astro-spotify-matrix/node_modules/netlify-builtin:astro/index.js' imported from /Users/me/.nvm/versions/node/v16.17.1/lib/node_modules/netlify-cli/src/lib/one-graph/cli-netlify-graph.mjs
Starting Netlify Graph session, to edit your library visit http://app.netlify.com/site-redirect/d1a964d6-a737-4e79-a222-e1d75c8729c3/graph/explorer/ed3748aa-8e31-40a7-bd74-ef3f66648737 or run `netlify graph:edit` in another tab

   ┌─────────────────────────────────────────────────┐
   │                                                 │
   │   ◈ Server now ready on http://localhost:8888   │
   │                                                 │
   └─────────────────────────────────────────────────┘

10:46:31 AM [astro] update /netlifyGraph.lock

I assure you, in netlify.toml I have

[graph]
  codeGenerator = "netlify-builtin:astro"

I tried installing Netlify CLI globally as well as part of this project as it seems it can’t find /node_modules/netlify-builtin:astro/index.js. However, the error persists.

Also, tried installing netlify-builtin via npm, but get an error that the package does not exist.

Hi @djmtype :wave:t6: apologies for the delay. Just wanted to keep you in the loop. Our team is looking into this still and we don’t have an update but we will soon.

Thanks for the followup!