Home
Support Forums

Website not loading (custom domain only) via VPN

I have the same website deployed to 2 domains:

  1. Netlify’s domain: https://sharp-euclid-d77d5a.netlify.app/
  2. Custom domain: https://www.nftarmory.me/

For some reason the latter won’t load behind my VPN. That’s a real problem because the product’s targetted at developers in a security-sensitive industry, so I imagine over half will have VPNs enabled.

All DNS settings are managed by netlify (default config).

Can you help me debug this? It would be a shame to have to move away from netlify because of what seems like a DNS issue.

Hi @dogetoshi

When did you configure the DNS? Do remember propagation takes time. Is there a specific VPN server location you are unable to connect from, or is it any location? Using the built-in Opera VPN I had no issue connecting to via the custom domain.

Thanks for chiming in.

Configured last night. You reckon this might be a timing issue?

I’ve tried different locations, from all over the world, with the same result.

Good to know Opera VPN works.

It is possible there are still some DNS servers that haven’t updated the relevant records.

That said, I used a different (non-free) VPN and successfully loaded your site from several locations.

Cool I’ll give this another 24h and will update the thread. Thanks again.

This was indeed a timing issue. Can be closed.
image
what more is there to say…

If you recently done DNS changing then there is only solution is wait. It may takes upto 24 to 48 hours to change the DNS. Sometime it comes up early sometime late.