View how many pages and how many assets are in my site?

My site (https://kentico-gatsby-loaddemo.netlify.app) was built using Gatsby and Kentico Kontent as a headless CMS. The CMS was loaded with approx 5000 content pages (in two languages), so I expect to have a site of approx. 10000 content pages. This seems in deed approx correct when I do a full deploy.
To know this, I need to look at a previous build/deploy and check the deploy logs.

What I can’t see, it the number of assets that my site holds. How can I retrieve that information?

You can download the deploy from the deploy details page and see the number of files.

Tx. I have tried that, but the download fails (after two minutes or so).

That’s strange. Are you sure any browser extensions or unstable network is not causing issues? Maybe try changing device/network?

image
After 1 minute:
image

I’ve tried in Firefox and in Chrome, bot pretty much vanilla releases. The error suggest it’s the (server side) ZIP generation process that is failing (so not really client related).

Not really. In my case, I still see the same error when ad-blocker or some other extension interferes. But yes, my websites are not that big.

I just wanted to clarify that the error might not always indicate a server-side problem and might be a client-side problem too. I’m not saying it’s client-side in your case, just wanted to clear that it can be an error on both the ends, and we can’t really pinpoint what it is exactly. Since you have tried multiple browsers, maybe the problem lies here, but again, I can’t confirm it myself.

I’m escalating this to the Support Team so that they can check what exactly the problem is.

Thanks for the feedback. I will try on another computer that’s not on our corporate domain, to avoid firewall, AV and other settings that might influence browser config.

Update: I tried it on a remote computer with Microsoft Edge “clean out of the box”: same behavior.
It just hit me to mention: when using any computer/browser to do the same for another (smaller) site in my subscription, it works. After a few minutes, I get the download link. But not for the larger site(s). Seems to be size related.

That makes sense, might be size related after all. I’m sure you’ll get an official confirmation on this soon enough.

Also, looking at this thread: Cannot download deployment - #28 by Durcheinander, seems like you’re not the only one who is unable to download super big websites.

Hey there, @RoeckieTM

Sorry for the slow response on this end. As Hrishikesh mentioned, it sounds like this is related to this thread, which is indeed a bug. I do not have an update on this bug for you. I know this is not the news you were hoping for.

That being said, our team is actively exploring options regarding how we can improve this aspect of our service. If there are any specifics you are looking for from your deploy, please reply and let us know.

Best,
Hillary