Support Forums

Using nic.is with Netlify / setting a TTL of 86400

Hi, I am having the same problem with straumkul.is

we took care of that for you, @SveinnB!

Thank you @perry. Can you do the same for arb.is, arbaerehf.is and husihus.is ? :slight_smile:

Hi, @SveinnB. This was done for arb.is.

For arbaerehf.is and husihus.is, the DNS zones don’t exist in Netlify DNS. We cannot the NS records until there is a DNS zone in Netlify DNS to update.

Please let us know when you add those zones and we’ll get the NS records updates for them as well.

Thank you @luke. arb.is will do for now :smiley: the hosting company for arbaerehf.is and husihus.is have redirects those url to arb.is for me. So this is working as expected now. Thanks again.

1 Like

Hi, I am having the same problem with mywish.is
Can you check it, please?

Hi, @xanderim. The TTL has been extended for mywish.is. If there are other questions or concerns, please let us know.

Hey, it seems it didn’t work for mywish.is
The TTL settings are still the same - 3600 seconds
And I still get an error when trying to set netlify dns.
Do you have any idea what can be done? Thanks.

@xanderim You’ll need to update your name servers to point to Netlify. Here’s some instructions: [Support Guide] How can I manage my DNS with Netlify if I used another vendor to purchase my domain?

And here are the name servers to use: https://app.netlify.com/teams/xanderim/dns/mywish.is#nameservers

Hi Laura. Thanks for your reply but I could not update my DNS because of the same error. I assume the reason is the wrong TTL (unfortunately Namecheap doesn’t provide me with a detailed error description). The TTL for nic.is should be 86400s and what I have in my domain settings is 3600s. I thought that your support team could extend the TTL for this domain

Hi Xander,

That record you’ve pictured shows a 3600 TTL. That record is not one that the Icelandic NIC has, in the past 100 or so folks we enabled this feature for, cared about. Only the nameserver records’ TTLs mattered in past instances. As Laura mentioned, these are your nameservers:

and when you use those nameservers to query, you can see that those are set correctly, to more than 86400:

% dig -t ns mywish.is @dns1.p02.nsone.net

; <<>> DiG 9.10.6 <<>> -t ns mywish.is @dns1.p02.nsone.net
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 14135
;; flags: qr aa rd; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 1
;; WARNING: recursion requested but not available

; EDNS: version: 0, flags:; udp: 1232
;mywish.is.			IN	NS

mywish.is.		86401	IN	NS	dns1.p02.nsone.net.
mywish.is.		86401	IN	NS	dns2.p02.nsone.net.
mywish.is.		86401	IN	NS	dns3.p02.nsone.net.
mywish.is.		86401	IN	NS	dns4.p02.nsone.net.

I guess you can contact namecheap’s tech support on whatever error remains, since our service is set up the same way for you as it was for prior posters and they work well - I think this is a namecheap, not a netlify setting problem :slight_smile:

However, I could be wrong or there could be something I don’t understand.
Please don’t hesitate to come back with a report from namecheap that setting X is the problem and should be adjusted to ABC - even if it doesn’t make sense, we can try setting it for them to see if it helps. I don’t think the TTL’s on NETLIFY records (which are basically A records) are the problem, though.

Thanks. You were absolutely right, Namecheap support did solve the DNS issue.


I seem to be having the same TTL issues with epenthes.is, and would appreciate assistance.

Hi, @hypoelliptical. There is no DNS Zone at Netlify for epenthes.is. I can extend the TTL only once a DNS zone is created.

Would you please create the zone first and then let us know when you are ready to proceed?

It should be up now. Unfortunately, I cannot point the DNS to Netlify’s from Namecheap’s control panel, because it errors out. Namecheap’s support claims:

You’ll need to contact your DNS provider and ask them to set up the nameservers correctly (presetup DNS zone, NS records should have TTL 86400 (24 hours) or more, nameservers hosts must not resolve to the same IP address).

Hey there @hypoelliptical,
The NS records for your site meet those requirements. You can see below that TTL is 86400:

% dig -t ns epenthes.is @dns1.p01.nsone.net

; <<>> DiG 9.10.6 <<>> -t ns epenthes.is @dns1.p01.nsone.net
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 55647
;; flags: qr aa rd; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 1
;; WARNING: recursion requested but not available

; EDNS: version: 0, flags:; udp: 1232
;epenthes.is.			IN	NS

epenthes.is.		86400	IN	NS	dns1.p01.nsone.net.
epenthes.is.		86400	IN	NS	dns2.p01.nsone.net.
epenthes.is.		86400	IN	NS	dns3.p01.nsone.net.
epenthes.is.		86400	IN	NS	dns4.p01.nsone.net.

;; Query time: 7 msec
;; WHEN: Fri Nov 20 14:37:37 PST 2020
;; MSG SIZE  rcvd: 129

Want to give it another try?

I can confirm that it works now. There were addditional issues between the domain registrar and ISNIC, which have now been solved.

Thank you for your assistance!

1 Like


I have the same problem, don’t understand any of this TTL things put have these two url that need 86400 TTL like the other in this tread.

These url. here:

I have already register those url on Netlify to the best of my knowledge.

Best regards!

Hey @Hilmar,
It looks like you’re not hosting your DNS with Netlify, so this looks like a slightly different issue. For pointing to your Netlify sites from an external DNS host, you’ll want to follow these instructions to set that up:

(Basically, from your DNS host, add an A record pointing to our load balancer IP address and a CNAME record pointing to your Netlify subdomain, i.e., otois.netlify.app)

Thank you Jen!

I’m going to read and try to understand.
I´m a designer so it is very likely that I will have some questions :slight_smile: