Support Forums

Using nic.is with Netlify / setting a TTL of 86400

I have a .is domain (Iceland) registered at nic.is . I wanted to use Netlify for my DNS. However, nic.is refused to set the DNS servers to Netlify because they have a check before they do the transfer that the NS records on the new DNS server have a TTL of 86400 seconds. Netlify DNS editor does not allow you to change the TTL on the root domain and www records, and it’s set to 3600. So, I ended up using cloudflare. Wondering if anyone has been able to get nic.is to work with Netlify DNS.

@foobarbecue - i made a new post, as this feels like it warrants a separate topic so that people can more easily find this :slight_smile:

We can set the higher TTL for you. What domain is it?

I have an open feature request to do this automatically for .is domains but until then it is a manual operation for which we’d need to know your domain to adjust settings.


Thanks! The domain is aaroncurt.is . Please set TTL to 86400.

1 Like

NO DEAL! I set it to 86401 since that’s worked well in the past :slight_smile: Should be ready to link now.


Hello! have the same problem with www.haleck.is domain

Hi @crazyjooe! Welcome to community.

We just took care of that for you.

1 Like

Thanks. I was able to change DNS in my domain dashboard. Now, it seems that changes have propagated, but I still don’t get a redirect from my haleck.is domain to netlify. I checked netlify settings and seems that TTL for all DNS records is back to 3600 again. I’m wondering if that’s the cause of my problem.

Sorry, when we made that update, we didn’t update how it looks in your dashboard, but in DNS, it is set right:

$ dig -t ns haleck.is

; <<>> DiG 9.10.6 <<>> -t ns haleck.is
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 18815
;; flags: qr rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 5

; EDNS: version: 0, flags:; udp: 512
;haleck.is.			IN	NS

haleck.is.		86401	IN	NS	dns4.p07.nsone.net.
haleck.is.		86401	IN	NS	dns1.p07.nsone.net.
haleck.is.		86401	IN	NS	dns2.p07.nsone.net.
haleck.is.		86401	IN	NS	dns3.p07.nsone.net.

Hi! I’m running into the same issue currently with www.sueioan.is. Please help me to update the TTL. :pray:

@michaelyuen, we have updated those records to match the required TTL value (86401 is what we normally use for .is domains). ​Please let us know if it doesn’t work for you when tested.

1 Like

@luke Any chance you could give me a hand with bryce.is? I’m having the same issue here. :pray:

@luke Yes, I’m happy to confirm it worked! May I ask for you to do the same for www.ioan.is and www.sioan.is? That will be all from me.

I just updated bryce.is for you

Those dns zones do not seem to be set up in our system yet, Michael. Must be configured here before I can update the config :slight_smile:

Thank you. It works! :partying_face:

I am having the same problem with my domain, jfd.is.

Hi, @jdepumpo, the TTL values for the NS records for jfd.is at Netlify have been increased to 86401.

If there are other questions or concerns, please let us know.

Same issue here with jolihjarta.is

Hi @macaroni! We just updated the TTL for jolihjarta.is. You should be all set now.

1 Like