Unwanted "reply-to" email header hijacking


It looks like Netlify will set the ‘reply-to’ header in the emails that are sent when a form is submitted to the value of a field of type ‘email’ in the form (I’ve experimented with setting the field to ‘text’ and it doesn’t get picked up, so it’s definitely due to type=‘email’). This feels a bit magic/presumptuous and has caused a few of my form submissions to be flagged as spam (because the from and reply-to domains didn’t match, and the reply-to was from a freemail service).

I’ve searched the docs but this behaviour doesn’t appear to be documented. Is it possible to disable/configure/override this feature somehow?

Otherwise loving the service - thank you!


Quite possible! Use a field name other than “email” to collect your email addresses, and it won’t happen :slight_smile:

We’ll try to get the docs updated to mention this!

That’s exactly what I’ll do for now, thank you :slight_smile:

The docs still say:

All form notification emails are sent from formresponses@netlify.com, and any replies to a notification will go to that address. If you would like to respond to a form submitter, you will need to enter their address manually.

No word about adding an <input> field with name="email" allowing to have an auto-filled Reply-To: header… :confused: Would be cool if the docs explicitly mentioned this!

hi @salim-b ,

we definitely are still hoping for a docs update on this one! We can let you know here once it is done. thanks!

1 Like