Home
Support Forums

Unable to get HTTPS for my custom domain

Hello,

I’m trying to get HTTPS for my custom domain instinct-reflexes.fr (trusting-einstein-c68f09), but I think I missed something (after waiting 36 hours).
My Netlify domain name and my primary custom domain (with www) are good, but not my primary custom domain without www (I have the error “Check DNS configuration” for this one and it says I have to set dns1, dns2, dns3 and dns4 but I did it already but without the www).
Do I have to set the dns1, dns2, dns3 and dns4 with and without the www ?

Thanks,

Regards,

David

No, it’s just supposed to be set for your non-www domain. The www version is created automatically by Netlify and depending on which one you set as ‘primary domain’, the other one will be redirected to it.

As I can see using DNS check, the nameservers seem to be in place, however, I’m not really sure why it’s not working.

Thanks Hrishikesh, for the time being, I have removed the www entries in my DNS zone on my domain name provider.
I have also set a few minutes ago CNAME to trusting-einstein-c68f09.netlify.app with www as a host name
and A to the IP provided by the nslookup but without www as a host name

If you’re going down that way, don’t set it to the IP shown by nslookup unless it’s same as 104.198.14.52. Read here: https://docs.netlify.com/domains-https/custom-domains/configure-external-dns/#configure-an-apex-domain

Thanks a lot Hrishikesh!
By changing the IP address you gave me, now I’ve got the green “Netlify DNS” flag on my instinct-reflexes.fr :slight_smile:
I hope I’ll get the HTTPS working in a fews hours after the DNS propagation!

1 Like

Hello,
finally I wasn’t able to get my https on my site.
I have the following error on https://app.netlify.com/sites/trusting-einstein-c68f09/settings/domain#https
We could not provision a Let’s Encrypt certificate for your custom domain.
Can I provide you my DNZ Zone file from my domain name provider safely ?
Thanks,
Regards,
David

It usually happens when there’s some error with the DNS, though, I’m not very sure what’s wrong. You can wait a little longer for an official reply.

I don’t think it would be necessary.

Thank you Hrishikesh, I’ll wait :slight_smile:

Hi, @clairepelletier85. This domain isn’t using Netlify DNS at this time:

$ whois instinct-reflexes.fr | grep "nserver"
nserver:      D.NIC.FR 194.0.9.1 2001:678:c:0:0:0:0:1
nserver:      E.EXT.NIC.FR 193.176.144.22 2a00:d78:0:102:193:176:144:22
nserver:      F.EXT.NIC.FR 194.146.106.46 2001:67c:1010:11:0:0:0:53
nserver:      G.EXT.NIC.FR 194.0.36.1 2001:678:4c:0:0:0:0:1
nserver:     dns2.alwaysdata.com
nserver:     dns1.alwaysdata.com

This issue is covered in the support guide here:

Please use one of the two solutions in the support guide above. If there are any questions about either solution, please let us know.

Hello Luke,

Ok, I’ll read this guide carefully and, as a last resort, I will join the support of my domain name provider because I set the NS as indicated in the Netlify documentation.

Thanks a lot,

David

Luke,

I’m not sure what means “Delete the inactive DNS zone”.
Is it on my domaine name provider or on Netlify ?
Do I have to delete all the DNS records ?

Thanks a lot for your help !

Regards,

David

Luke, Hrishikesh,
it seems I didn’t put the NS at the right place on my DNS provider,
it seems ok now, I get this on https://app.netlify.com/sites/trusting-einstein-c68f09/settings/domain#https:
Your site has HTTPS enabled
Certificate
Let’s Encrypt
Domains
instinct-reflexes.fr, www.instinct-reflexes.fr
Created
Today at 2:01 PM
Updated
Today at 2:01 PM
Auto-renews before
Feb 7, 2021 (in 3 months)

:heart_eyes: