Support Forums

Unable to deploy

I just entered “git clone https://github.com/devcows/hugo-universal-theme”, which is NOT a submodule and I keep getting the following error “7:36:38 PM: Build ready to start
7:36:40 PM: build-image version: b0258b965567defc4a2d7e2f2dec2e00c8f73ad6
7:36:40 PM: build-image tag: v3.4.1
7:36:40 PM: buildbot version: 0a44c930054be748eff0c581d346282fece89cc0
7:36:40 PM: Building without cache
7:36:40 PM: Starting to prepare the repo for build
7:36:41 PM: No cached dependencies found. Cloning fresh repo
7:36:41 PM: git clone https://github.com/GerBreOwn/myraspi.me
7:36:43 PM: Preparing Git Reference refs/heads/main
7:36:45 PM: Error checking out submodules: fatal: No url found for submodule path ‘themes/hugo-universal-theme’ in .gitmodules
7:36:45 PM: Failed during stage ‘preparing repo’: Error checking out submodules: fatal: No url found for submodule path ‘themes/hugo-universal-theme’ in .gitmodules: exit status 128
7:36:45 PM: Failing build: Failed to prepare repo
7:36:45 PM: Finished processing build request in 4.919046348s”

I have deleted the .gitmodules file from my computer and my github repo so where is this error coming from??? When I restart a build I choose “CLEAR CACHE”

If I may ask, where exactly are you trying to clone the repository? I mean, that repository you’re cloning goes in the themes folder of your Hugo website and it probably cannot be used as a standalone website. Can you please confirm if you’re doing it correctly, that is, cloning that theme in the themes folder and not trying to deploy it directly?

I would have checked it myself, but, the address: https://github.com/GerBreOwn/myraspi.me returns a 404. Either it’s a private repo, or you might have deleted it. In either of the cases, let’s just make sure you’re doing it right.

I believe you already made a post regarding this issue.
If there is one source of truth you will find your answer much quicker:

Thanks for your reply.

It is in the themes directory put there twice after deleting it the first time.

The repository IS a private repository. Does it need to be a public one? It was working fine until I tried to use the “hugo-book” theme which is a submodule and I could not get that to work and have been having this problem ever since then. When I deleted it maybe I didn’t do it correctly as it thinks the .gitmodules file is still there even though I can not find a file with that name anywhere on my computer nor in my repository. When I try to start a new deploy I always tell it to “clear the cache” but looks like it is not doing that.

Is there a way I can access my files on Netlify and maybe delete it from there?

The new one is “hugo-universal-theme” which is NOT a submodule as their instructions say to “cd to themes”, then " git clone ", which is what I did.

Any other ideas on how I can make this problem go away?


Gerald Brown

No, you can definitely keep your repos private.

Sadly, no.

Is the website working fine locally? Because if it’s not, maybe you can ask this on Hugo forums too to see if they have any experience with this problem?

Would it be possible for you to try starting fresh?

Deleting submodules is a notoriously difficult issue for the first time. It may look deleted but the repo is still requesting it. I did reply to your other post with a stackOverflow suggestion that worked for me?
However, as hrishikesh has said, you could start over, and by that, we mean do not clone your current repo, create a new one.

1 Like