Unable to change my email address in usersettings


I want to change the Email address that is listed in the usersettings (top left usericon => General => Profile=> Personal information) in https://app.netlify.com/user/settings#personal-information. After changing it I get a verification email sent to the new email address. When I click the verification link I get a page that says my link is expired.

I tried several times, the email appeared within 2 minutes in my inbox Clearly something is buggy here…

How can I change that email address?

You’re on the right path.

We’ve delivered a lot of reset emails to your address in a row - you must please use the LATEST link - and, note they are only good for 30 minutes.

Sorry, but I never receive any emails. I just retried changing the email address again and follow these procedures. I created another topic for the same issue.

hi marc, i just commented on your other thread - i didn’t see there were more than one. Did you check your spam filter? who is your email provider?

Hi Perry,

Hostek.com is hosting my marcbakker.com domain but also using my Gmail email address doesn’t get me any verification emails. I just noticed one from the many I requested got through - on Fri, 12 Jun, 16:51 to webdev@marcbakker.com.

Is there an alternative way of changing marc@wincacademy.nl to webdev@marcbakker.com?

Your mailserver is bouncing our emails to that second address, so that won’t help much. Here’s the bounce message you’ll need to resolve before we can update our system to begin sending to it again. Please follow up here to let us know you have done so, so we can flip that additional switch.

I am sending you this message to inform you on the delivery status of a
message you previously sent.  Immediately below you will find a list of
the affected recipients;  also attached is a Delivery Status Notification
(DSN) report in standard format, as well as the headers of the original

  <webdev@marcbakker.com>  delivery failed; will not continue trying

Content-Type: message/delivery-status

Reporting-MTA: dns;mail187-4.suw11.mandrillapp.com
X-PowerMTA-VirtualMTA: mail187-4.suw11.mandrillapp.com
Received-From-MTA: dns;pmta01.mandrill.prod.suw01.rsglab.com (
Arrival-Date: Mon, 22 Jun 2020 17:59:57 +0000

Final-Recipient: rfc822;webdev@marcbakker.com
Action: failed
Status: 5.0.0 (undefined status)
Remote-MTA: dns;mail.marcbakker.com (
Diagnostic-Code: smtp;554 Sending address not accepted due to spam filter
X-PowerMTA-BounceCategory: content-related

To answer your next question, there is no way for you to change your login except to be able to receive email at your current one.


I just checked with my hosting provider where I host the email address webdev @ marcbakker. com. Just a recap 2 be sure we’re on the same line:

  1. I try to change my current registered email address marc @ wincacademy. com to webdev @ marcbakker. com;
  2. The verification emails that are sent never arrive at that address (webdev @ marcbakker. com)
  3. Today a few verificatin emails should be sent to webdev @ marcbakker. com
  4. My hosting provider cannot see any email coming from team @ netlify to webdev @ marcbakker. com in todays logs;

This is what he sees in todays logs:

(Had to alter the mailto links to circumvent your posting policy of not more than 6 links in a post)

The only emails I can see coming to the account today are shown in the logs below.

[2020.06.23] 05:38:32.231 [97283] Delivery started for [01000172e0c1fc2d-ee15dfd6-7b27-4a34-a79c-c399ab2532f6-000000 @ amazonses. com](mailto:01000172e0c1fc2d-ee15dfd6-7b27-4a34-a79c-c399ab2532f6-000000 @ amazonses. com) at 5:38:32 AM
[2020.06.23] 05:38:47.278 [97283] Added to SpamCheckQueue (0 queued; 2/50 processing)
[2020.06.23] 05:38:47.278 [97283] [SpamCheckQueue] Begin Processing.
[2020.06.23] 05:38:47.278 [97283] Starting Spam Checks.
[2020.06.23] 05:38:57.247 [97283] Spam check results: [REVERSE DNS LOOKUP: 0,Passed], [_SPAMASSASSIN: 6:6], [_SPF: 0,None], [HOSTEKBL: 0,passed], [HOSTEKBL IP SET: 0,passed], [INVALUEMENT: 0,passed], [INVALUEMENT URIBL: 0,passed], [SPAMCOP: 0,passed]
[2020.06.23] 05:38:57.247 [97283] Spam Checks completed.
[2020.06.23] 05:38:57.247 [97283] Removed from SpamCheckQueue (1 queued or processing)
[2020.06.23] 05:38:59.309 [97283] Added to LocalDeliveryQueue (0 queued; 1/50 processing)
[2020.06.23] 05:38:59.309 [97283] [LocalDeliveryQueue] Begin Processing.
[2020.06.23] 05:38:59.309 [97283] Starting local delivery to [webdev @ marcbakker . com](mailto:webdev @ marcbakker . com)
[2020.06.23] 05:38:59.372 [97283] Delivery for [01000172e0c1fc2d-ee15dfd6-7b27-4a34-a79c-c399ab2532f6-000000 @ amazonses . com](mailto:01000172e0c1fc2d-ee15dfd6-7b27-4a34-a79c-c399ab2532f6-000000 @ amazonses . com) to [webdev @ marcbakker . com](mailto:webdev @ marcbakker . com) has completed (Delivered) Filter: Spam (Weight: 6), Action (User Level): PrefixSubject
[2020.06.23] 05:38:59.372 [97283] End delivery to [webdev @ marcbakker . com](mailto:webdev @ marcbakker . com) (MessageID: <[01000172e0c1fc2d-ee15dfd6-7b27-4a34-a79c-c399ab2532f6-000000 @ email.amazonses . com](mailto:01000172e0c1fc2d-ee15dfd6-7b27-4a34-a79c-c399ab2532f6-000000 @ email.amazonses . com)>)
[2020.06.23] 05:38:59.372 [97283] Removed from LocalDeliveryQueue (0 queued or processing)
[2020.06.23] 05:39:02.309 [97283] Removing Spool message: Killed: False, Failed: False, Finished: True
[2020.06.23] 05:39:02.309 [97283] Delivery finished for [01000172e0c1fc2d-ee15dfd6-7b27-4a34-a79c-c399ab2532f6-000000 @ amazonses . com](mailto:01000172e0c1fc2d-ee15dfd6-7b27-4a34-a79c-c399ab2532f6-000000 @ amazonses . com) at 5:39:02 AM [id:-624277297283]

With current address you mean marc@wincacademy, not webdev@marcbakker.com?

As far as I can tell, as recently as 14:29 UTC yesterday, 23 Jun, webdev@markbakker.com was still bouncing. I have just tried to send a new password reset for you and it made it through, huzzah!

As far as I can tell there is no login here for anyone @winacademy.com so I think isn’t involved yet :slight_smile:

Good news, the "Please verify your new email address"mails to webdev@marcbakker . com do come through. Now when I click the link I am redirected to a netlify page that says “This link has expired Please check your email for the most recent link or visit the user settings page to request a new one.”.
It came throught within minutes after clicking ‘save’ on your website and as soon as I got it I clicked the link Same as yesterday.

Below part of the original mail headers:

Received: by 2002:ac8:f8c:: with POP3 id b12mf3282055qtk.1;
        Thu, 25 Jun 2020 06:34:35 -0700 (PDT)
X-Gmail-Fetch-Info: webdev@marcbakker. com 13 mail.marcbakker. com 110 webdev@marcbakker. com
Return-Path: <bounce-md_31128206.5ef4a7c0.v1-976125a9b09e4109829696dd509f0b80@smtp-out-md.netlify. com>
Received: from mail128-135.atl41.mandrillapp. com (mail128-135.atl41.mandrillapp. com []) by mail9.hostek. com with SMTP (version=TLS\Tls12 cipher=Aes256 bits=256);
   Thu, 25 Jun 2020 08:33:54 -0500
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; s=mandrill; d=netlify. com; h=From:Subject:Reply-To:Message-Id:To:Date:MIME-Version:Content-Type; i=team@netlify. com; bh=V7fr4JdR2uZsuwUcW7LGN86wKdE5ABbJay5imAhhbgc=; b=lmuFxkzEY+dpSK6gbO2Ylpx6RkDm41msFmHJpBXCI5WV0K1HvDL4JVgNKfB9lRGJRrykKPANC3TJ
Received: from pmta01.mandrill.prod.atl01.rsglab. com ( by mail128-135.atl41.mandrillapp. com id huijs41mqukh for <webdev@marcbakker. com>; Thu, 25 Jun 2020 13:33:53 +0000 (envelope-from <bounce-md_31128206.5ef4a7c0.v1-976125a9b09e4109829696dd509f0b80@smtp-out-md.netlify. com>).

What’s the time -out setting of these links?

They shouldn’t time out before 30 minutes! Can you try copying the link from the email and pasting directly in to your browser?

I just tried @ 16:41 CET with an email that was sent minutes earlier from your website. Same result. Below the email headers:

Received: by 2002:a0c:fe90:0:0:0:0:0 with SMTP id d16csp547682qvs;
        Thu, 25 Jun 2020 07:38:37 -0700 (PDT)
X-Google-Smtp-Source: ABdhPJw6UisZY+H28xDIOdnghPj5xuOgLHhvdBPJv2EEovahqmRXP20xU11htcQeW40itgJT1DzJiGsAqME=
X-Received: by 2002:ac8:60c8:: with SMTP id i8mr22024867qtm.271.1593095916539;
        Thu, 25 Jun 2020 07:38:36 -0700 (PDT)
Authentication-Results: mx.google.com;
       spf=pass (google.com: domain of bounce-md_31128206.5ef4b6cd.v1-853815d0d243458aa9b237349ec7a9bc@smtp-out-md.netlify.com designates as permitted sender) smtp.mailfrom=bounce-md_31128206.5ef4b6cd.v1-853815d0d243458aa9b237349ec7a9bc@smtp-out-md.netlify.com;
       dkim=pass header.i=@netlify. com header.s=mandrill header.b=mStY0XTQ;
       dkim=pass header.i=@mandrillapp. com header.s=mandrill header.b=nt8zIqbh
Received-SPF: pass (google. com: domain of bounce-md_31128206.5ef4b6cd.v1-853815d0d243458aa9b237349ec7a9bc@smtp-out-md.netlify. com designates as permitted sender) client-ip=;
Received: by 2002:aed:3422:: with POP3 id w31mf2924769qtd.2;
        Thu, 25 Jun 2020 07:38:36 -0700 (PDT)
X-Gmail-Fetch-Info: webdev@marcbakker. com 13 mail.marcbakker. com 110 webdev@marcbakker. com
Return-Path: <bounce-md_31128206.5ef4b6cd.v1-853815d0d243458aa9b237349ec7a9bc@smtp-out-md.netlify. com>
Received: from mail187-4.suw11.mandrillapp. com (mail187-4.suw11.mandrillapp. com []) by mail9.hostek. com with SMTP (version=TLS\Tls12 cipher=Aes256 bits=256);
   Thu, 25 Jun 2020 09:38:06 -0500
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; s=mandrill; d=netlify. com; h=From:Subject:Reply-To:Message-Id:To:Date:MIME-Version:Content-Type; i=team@netlify. com; bh=ZW74gcTJrY7u6yUZZ/fWUx7pi+rFPVPUwitQFpxJAKQ=; b=mStY0XTQGRp2tp96cmfhXMDvqkj4VHAsJL5pGOfQMssjNZgu5MgRR/6WBMznHkCyl9WpU64JgB+T
Received: from pmta01.mandrill.prod.suw01.rsglab. com ( by mail187-4.suw11.mandrillapp. com id huircs174i42 for <webdev@marcbakker. com>; Thu, 25 Jun 2020 14:38:05 +0000 (envelope-from <bounce-md_31128206.5ef4b6cd.v1-853815d0d243458aa9b237349ec7a9bc@smtp-out-md.netlify. com>)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=mandrillapp. com;

This should be independent from the front end - the request uses this link without any modifications. So does it take the timedifferences between Europe and your location in the US into account?

Hey Marc,

thanks for your patience as we work on this. We did some digging, and it seems to be that the email address you are trying to change to already exists under another account - is this something you are aware of? are you trying to merge two accounts or maybe forgot you had a different account?

We’re working on making our messaging a bit more transparent, but in the mean time, I want to make sure that things are working as you’d expect. Can you give us an update into what is or isn’t working? Are you receiving emails? thanks.

Hi Perry, that’s correct. I have another netlify account that uses the email address I wanted to change to Totally forgot… .I reset the password so problem solved.
Adding a message to the errormessage (‘we found another account with the email addres you are trying to change’) would help a lot…

Thanks for the help!


1 Like

great, glad its resolved now!