Home
Support Forums

Timing out during post processing

Hi I’m having trouble deploying my site.
It’s jusing the NextJS plugin.
The build completes, but the “post processing HTML” part times out. What is this actually doing and how can I troubleshoot it?
I have looked around a bit online and see that it might be due to the sites size, is this likely to be the case?
Is there anyway to allow for more time here?
I’ve added my card to my account.

Logs below

11:12:50 AM: ────────────────────────────────────────────────────────────────
11:12:50 AM: Netlify Build Complete
11:12:50 AM: ────────────────────────────────────────────────────────────────
11:12:50 AM: ​
11:12:50 AM: (Netlify Build completed in 13m 40.4s)
11:12:51 AM: Starting post processing
11:12:51 AM: Post processing - HTML
11:12:51 AM: Execution timed out after 16m21.124619449s
11:12:51 AM: Error running command: Command did not finish within the time limit

Postprocessing is a part of the build and thus, the 15-minute timeout applies to it as well. This entire thing should finish within 15 mins. The timeout for the build can be increased, which site would you need it for?

Also, if you’re not using any Post processing like asset optimisation, form detection or snippet injection etc., you could disable all of it here: https://app.netlify.com/sites/site-name/settings/deploys#post-processing to save you some build time.

https://playlumi.netlify.app/
Thanks please increase the timeout for this site.
I’ll take a look at those settings too

The timeout has been updated.