Sveltekit 1.0 and Netlify - whats up with the adapter/build?

Site: peppy-rolypoly-dd9af0
Info: Sveltekit1.0, Netlify-cli 12.7.2.
Adapter: adapter-netlify
Netlify.toml:
[build]
command=“svelte-kit build”
publish = “build”

Issue: If I run ntl dev (ie locally), app is running fine locally. If I run ntl deploy it asks me if I forgot to run build, so i run npm run build and it creates a build folder and I then run ntl deploy and it deploys fine and also runs fine online. However, if I now want to continue developing locally so I run ntl dev, the app is a complete mess. I mean it wasnt too pretty to begin with but now nothing works, navigation, css - all a mess. BUT … if I DELETE the build folder and run ntl dev, then my app is working fine again locally.

I also tried adapter-auto and that did not work either.
I tried setting the build folder to .svelte-kit but nada.

Are you aware that sveltekit is now creating a .svelte-kit folder for build?
Is npm run build still correct for ntl deploy?
Who writes the netlify-adapter?

Hi @kreollc ,

I just responded to you please do not make multiple threads as it slows our response. I will close this thread. If you have more questions can you please respond in the initial thread. Thanks!