Support form on is not working

Trying to get help but the support form is not working on your support page. Support | Netlify.

This appears in console when I submit
Screenshot from 2021-06-09 10-21-55

Hi @newxan,

Sorry to hear this.

I successfully submitted using the form a moment ago. Perhaps you could refresh the page and try again?

Is there any chance you’d be willing to share the content of your message to us which you were trying to share on the /support page?

Certainly. This is the exact message I’m trying to send.

Hi, I have a question regarding split testing.
I have the following split setup

1 branch master with the default production environment at 50%
1 branch seo_opt_1 with a deploy preview at 50%
Lets say i want to rebuild my site because I published a new article to for example contentful.
I trigger a new deploy either by a build hook or manually from the UI. This allows visitors that get the master branch experiment to see the updated build, but those that get the seo_opt_1 experiment are stuck with the old build and can’t see the new article.

I can’t figure out if this is how it’s intended but it seems to be this way. So what I figured then is that i should rebuild the seo_opt_1 preview deploy and that would update the split test automatically but for those visitors that get the seo_opt_1 experiment. But even after redeploys i keep getting the old version. I even tried pushing a new commit in case it was somehow linked to commit hashes.

Is there any obvious thing that I’m missing on how to promote changes to deploys that are part of a split test?

I did a test where I cleared the message and simply submitted test. which unfortnuately worked. So something with the original message is messing up the validation.
Also sorry for spamming a test message to your support.

For reference, Yesterday I posted this about getting help with split testing Updates to running split testing branch are not published
But got no answers, so I thought I’d use the regular support channel to get help, but failed due the form not submitting.

Hi there, @newxan :wave:

Thanks for bringing this up, and welcome to the Netlify Forums :netliconfetti: I have chatted with our Engineers and we will look into why the support form produced that error.

Regarding your split testing question, this is a great thread to check out for more context on how it works. Essentially, if everyone needs to see the new article, both branches will need to be updated. Let us know if the linked thread helps you. :slight_smile:

Lastly, as a Starter Level customer, you have access to the Support Forums for Support. Please note that the Support Forums do not have a guaranteed response time, and that we will respond to your post as soon as we are able to. Our team supports millions of sites, so we appreciate your understanding here. Guaranteed response times are available to different level customers, so should you determine that this would better fit your needs you can check out our pricing page!

Thank you for clearing that up.

I read through the thread you linked, and I think I understand how split testing works, but I’m not seeing an explaination for the behaviour I’m observing. Your comment and that thread suggests that I should update the branch (seo_opt_1) and I should see the update also in the related split test.

I do see the update if I go directly to that branch’s (seo_opt_1) deploy preview url. However I do not see the updated version if I go the production environment running the split test and getting assigned the nf_ab that should represent the same branch (seo_opt_1).

I’ll try on more time to push a commit to the branch i want updated in the split testing just to make sure.
Edit: Updating the branch did not yield any results unfortunately. Could this perhaps be related to “Branch Deploys”/“Deploy Previews”, even though I’m able to select the “Deploy Preview” branch from the list while configuring the split testing?

Any chance you can share the branch deploy preview URL and the prod URL for the content?

Sounds like URLs are working, and the custom domain isn’t. If that’s the case, on a whim, are you proxying to Netlify via Cloudflare or using custom cache-control headers?

Lastly, sanity check – make sure the files/assets are available on the branches prod deploy.

If you need/want a little further explanation/demonstration of Split Testing, I recommend Split testing with Netlify - Jamstack Explorers


Not using cloudflare, and checked the our headers with your articles suggestion and it looks okay.

I can PM you the links to the deploy.

Did you have a chance to look at the URLS?

Yes, sort of. We’ll only split based on the Production branch!

Lastly, sanity check – make sure the files/assets are available on the branches prod deploy.

Whereas you have mentioned an ‘incorrectly mirrored deploy preview’. We’ll never split on a deploy preview – you’ll want to push the changes to Prod :+1:.

That seems counter intuitive. If I can’t actually use deploy previews in split testing, why are they even available to be selected in the split testing setup?

Actually, after reading your reply several times over. I don’t understand at all, I think we’re talking about two separate things. My english is not always 100%, would if be possible to schedule a zoom call or something and try to get past the language barrier?

Hi, @newxan. You can split test between two different branches. The issue here is that you disabled branch deploys for one of the branches in the split test - the branch seo_opt_1.

Here is the important factor:

  • The split tests use branch deploys - not deploy previews - for the split.

You had the branch seo_opt_1 configured for branch deploys. However, on June 3rd, you removed that branch from the site’s deploy settings. You still have deploy previews enabled for the production branch so, because that branch is configured in a PR merging into master we are still triggering builds for that branch as deploy previews only. The branch deploys stopped back on June 3rd.

The last branch deploy for seo_opt_1 was deploy id 60b902c0f67f5500071e691e. This is the most recent branch deploy for that branch. Yes, there are newer deploy previews for that branch but deploy previews are not used for split testing. This is why the split test is stuck on the June 3rd deploy. Because that is the day branch deploys for seo_opt_1 were disabled.

To resolve this, go to the site settings (under Site Name > Settings > Build & deploy > Continuous Deployment > Deploy Contexts) and add the seo_opt_1 branch back. Then you still need to trigger a new deploy for that branch to update the branch deploy.

If that doesn’t work or if there are any other questions, please let us know.

About this:

We only provide phone/video support if two qualifications are met:

  1. The team is an Enterprise plan team.
  2. There is a signed custom support contract which adds phone or video call support.

These custom support contracts typically start at no less than $2000 a month with a twelve month minimum contract. If you are interested in upgrading to Enterprise with a custom support contract with phone support, please let us know and we will have our sales team contact you.

If you would like to keep troubleshooting here, please reply anytime.

1 Like

Thank you for clearing it up.
TL:DR for future reference:
I guess I got mixed up by having seo_opt_1 as branch deploy and then removing it, and since it still showed up in the list in the split setup, I incorrectly assumed that deploy previews can be used for split testing.

Thanks again for the help.