Suddenly getting 429 errors on all builds

I have been using Netlify in combination with CodeSandBox for about a year and it’s been working wonderfully. But, it seems that something changed this morning and now all my builds are failing with a 429 error. Perhaps this is something transient due to limited server resources available for folks on a free plan like me. Or perhaps I’ve overused my access in some non-obvious way. Or perhaps there’s something wrong with my configuration that needs to be updated.

My most recent successful build/deploy was last night at 11:50 PM PDT to https://starview.netlify.app/

My source is at https://github.com/Equal-Vote/star-view

I would typically deploy by forking https://codesandbox.io/s/github/Equal-Vote/star-view
followed by building to whatever site name Netlify assigned. To go live, I’d delete or rename starview then change the name of the freshly built site to starview. I’m sure there is probably a better way to accomplish this, but I’m providing all these details in case they are helpful in diagnosing my problem.

I also tried this morning to set up CI to musing-dijkstra-4f5da2. This also fails, and might be due to the same or a different reason. I just added the CI integration this morning as a possible way past my build failures. I’ve never seen that build succeed yet.

I’ve also tried deploying from star-view-v2 - CodeSandbox which is tied to my github repo and have been getting this error for the past hour or so:

2021-05-25 15:23:44.088 - | cp: cannot stat ‘/tmp/deploys/o4w9k/ckp46u2ki000z0uo0f32udgrv/source//_redirects’: No such file or directory

I do have a _redirect file in my /public folder which has been working fine. But just in case something changed on the Netlify side, I copied that _redirect file to the root of my github repo. No help.

I also get the same error deploying https://codesandbox.io/s/bidenvp-sv6l1 which I haven’t touched in months and was previously deployed to https://metavote.netlify.app/. All this leads me to suspect that the issue is environmental or a change with Netlify rather than a bug in my code. Unless of course, it is a latent bug that had previously gone undetected.

Thanks in advance for help troubleshooting and resolving this problem!

And now the problem is gone and builds are completing normally. I guess it was just an issue of server load.

Hey there, @jaycincotta :wave:

Thank you so much for circling back and letting us know! I am glad that this resolved itself :netliconfetti: