Subdomain pointing to WordPress installation

PLEASE help us help you by writing a good post!

  • we need to know your netlify site name. Example: gifted-antelope-58b104.netlify.app
  • DNS issues? Tell us the custom domain, tell us the error message! We can’t help if we don’t know your domain.
  • Build problems? Link or paste the FULL build log & build settings screenshot

The better the post - the faster the answer.


Hey folks,

I know that this question has been chewed over in previous discussions (here, here, and here) but after reading through the threads and attempting to use the posted solutions I’m still at an impasse.

I have a custom domain, bought from goDaddy with nameservers pointing to Netlify, hosting with Bluehost with a WordPress installation on a subdomain. I would like to be able to access this wordpress site by going to subdomain.mysite.com and having it directed to the IP of the wordpress server.

I have tried adding an A record with the IP address shown on Bluehost under the A(host) panel but when attempting to visit the page subdomain.mysite.com I receive a DNS_PROBE_FINISHED_NXDOMAIN.
I also tried using a CNAME and this returned a 404.

I realize this crosses the boundary of Netlify but am hoping someone might be able to point me in the right direction.

here a link to the site

What you tried with the A record should work.

Basically, the A record should be your subdomain name (say ‘admin’). You can create a record called admin with the IP address as the one in BlueHost. However, you’d also need to have the domain added to your BlueHost panel.

If it’s not working, maybe you can also share your actual domain name (with the subdomain in question) so we can check what’s happening.

Thanks for the quick reply.

the site in question is www.karellelangevin.com and the subdomain is wp.karellelangevin.com
however now the domain is giving me and ERR_CONNECTION_CLOSED and the subdomain is timing out.

Your custom domain loads fine for me. Connection Closed error is usually caused by some client side configuration. If possible, could you share the request ID for the failed request. It will be available in your browser’s developer tools’ network tab. I just turned my system off so I can’t show where. But it’s not too difficult to find.

The subdomain however is giving me a connection reset error. I believe it’s a error from BlueHost but again, the request ID might help.

I don’t see any request ID in network tab. It just times out and then says This site can’t be reached, it took too long to respond.

@dfr The way I do this is using a CNAME DNS entry, not an A record. However, my WordPress hosting has its own subdomain in addition to the shared IP address, which makes this trivial.

Hi Greg,

why might I ask is it trivial in that situation?

@dfr It is trivial because you have two FQDNs, and are just pointing one at the other.

Thank you for your responses. I am able to create subdomains in Bluehost but using a CNAME DNS entry does not seem to solve the problem. Is there further information I could give you to make this clearer?

@dfr Can you provide the Bluehost subdomain name?

wp.karellelangevin.com

@dfr No, that’s your custom subdomain. I was asking for the subdomain you set up on Bluehost – something like karellelangevin.bluehost.com.

the one I set up one Bluehost is wp.karellelangevin.com
the one I set up on Netlify was api.karellelanagevin.com

Each of these is a custom subdomain. To make the CNAME method work, you will need a subdomain you set up on Bluehost – something like karellelangevin.bluehost.com.

In that case I’m not sure I have the ability to create an actual subdomain with mydomain.bluehost.com
If I navigate to the panel for creating new subdomains they end up being formatted as previous

@dfr That’s what I suspected. You may have to use a redirect, although it’s not optimal.

Why is a redirect not optimal
and why wont an A record work?

Sorry if these are completely obvious

Hi, @dfr. You moved the DNS for this domain to Netlify DNS so would need to add the DNS record here:

https://app.netlify.com/account/dns/karellelangevin.com

It looks like you created the required DNS record there now and it is working when I test. Note, the SSL certificate isn’t working for wp.karellelangevin.com and we are unable to provide the SSL on systems outside of our direct control at Netlify.

In other words, because the IP address for this domain name (the subdomain wp - meaning for wp.karellelangevin.com) points to 162.241.224.194 and because that IP address isn’t controlled by Netlify - we cannot provide the SSL for that subdomain.

If there are other questions about this, please let us know.

hi @luke, it looks like everything is working as expected now. I’m just curious, initially I had set up the A record on Netlify but it was still giving me errors, was this just a matter of waiting long enough for the DNS changes to take effect?

Hi, @dfr. I don’t have the historical data for individual DNS queries so all I can do is guess. If the issue was still reproducible we could troubleshoot to say for certain.

I can give a “best guess” though and two possibilities seem plausible:

  • The previous DNS records were still in an upstream resolver cache. (TTL issues)
  • There was an error at Netlify which was fixed by deleting and then adding back the same A record (which successfully created the record on the second try).

If you click the TTL (time to live) issue link above, there is more information about how TTLs affect DNS record changes. This is the most common reason for DNS issue, but there are many other possibilities. TTLs are universal to DNS. TTLs are actually a very good good thing we live with the downside of caching issues because the benefits of TTLs are so great.

The second issue mentioned happens when you create the DNS record at Netlify but the record only appears to exist the web UI when in reality it doesn’t exist (meaning it doesn’t exist in both systems that are required to have it). In those cases, deleting and adding the record again fixes the issue because now the record does exist in both systems. There is an open issue files to correct that behavior (to fix the “not in both systems” behavior).

Again, it could have been something else completely. Just explaining the possibilities.