SSL not working for brach deploy subdomain


I have created a branch subdomain for my app, and that is working fine. It’s included in my SSL certificate.

When I did the same thing with the branch subdomain for my app, it never gets included in the SSL certificate, so that won’t work. I tried clicking “Renew certificate” and waiting for 24 hours without any luck. It’s the same Netlify account, the same domain name, and the same DNS configuration. So I don’t understand why one would work but not the other one.

So, to summarize. I am trying to set up the branch subdomain for my app where my primary domain is app[dot]purchal[dot]com (I wasn’t allowed to add more than 6 URLs in my post :woman_shrugging:), but it won’t work because of the SSL certificate. The DNS CNAME is already created, but the SSL is not working. Is there anything you can do to help?

Kind regards,

I think, wildcard SSL certificates can only be enabled by the Support Team. So, you’ll have to wait for them to reply.

1 Like

Hey there, @Purchal

Welcome to the Netlify Forums :netliconfetti: Thanks for reaching out.

You’ve configured our service to host your DNS, but you have not changed the DNS settings at your registrar to actually use our DNS hosting.There are two easy options to fix this, so please check out this Netlify Support Forums post to see the instructions!

This is another Support Guide that has helpful information about Branch Deploys and DNS.