SSL cert doesn't seem to be resolving for my primary domain

PLEASE help us help you by writing a good post!

  • we need to know your netlify site name: ilyrismedia.com
  • DNS issues? Tell us the custom domain, tell us the error message! We can’t help if we don’t know your domain. - The domain is ilyrismedia.com, the error message is just that the site is "insecure"

Here are some screen shots I can provide based upon what I am experiencing.

image

image

Hi, @ilyris. The SSL cannot be provisioned because there is a inactive Netlify DNS zone here:

https://app.netlify.com/account/dns/ilyrismedia.com

We have a support guide about this type of issue here:

There are two solutions in that support guide (delete the zone or activate it). ​Please let us know if there are any questions or if your chosen solution doesn’t work for any reason.

So, I might be a little dense here. To active the DNS zone on netlify, which is what I think I want in order to let your service always set up the SSL for the app, I would need to move my domain information over. Is that more than just pointing the A-record to the DNS for netlify?

Hi, @ilyris. There is a support guide about moving domain to Netlify DNS here:

@ilyris To resolve this, you need either to delegate DNS to Netlify or remove the domain from the Netlify Domain page and allow your registrar to handle DNS duties, but it appears you already transferred DNS duties to Netlify from Launchpad.

I am hosting through hostgator and reached out to them to change the DNS name servers to the 4 DNS zones, I do remember doing this on Namecheap, but couldn’t find a way on Hostgator to do it manually. They assumed me it should be done which should resolve in 0-48 hours.

Hopefully that resolves the issue.

Hey,

On the SSL section of your UI, can you try renewing the SSL certificate? Looks like the non-www domain didn’t get added. It probably propagated later than the www subdomain!

https://app.netlify.com/sites/ilyrismedia/settings/domain#ssl-tls-certificate

Howdy,

I am renewed the cert from that SSL HTTPS section of the interface.

I now see the cert, that’s fantastic news. Now it will be encrypted and Google can stop yelling at me. :slight_smile:
Thanks @Netlify_team

1 Like