Small file takes excessevely long time to upload

(when creating a topic it asked to give this info so:)

  • Netlify site name is: silver-store
  • There is no custom domain or error message
  • “There is no log for this deploy”

I uploaded a deploy for an existing website and when usually for 1-3 mb files it takes a couple secconds to upload. my 5 mb (megabite) file was not deployed for over 3 hours.

efter the previously mentioned 3 hours, i tried restarting my pc, and redeploying the file, I then waited a day and the file still hasnt uploaded. I redeployed the file after restarting my PC again, its been over 20 minutes and the (extra small) file still hasnt uploaded.

Additional information:

• at the moment the deploy says "site deploy in progress" • the file is 5 megabites large • there are 16 files in the folder • the folder does include a index.html • i have tried deleting the origional website and creating a new deploy witch didnt work • the file has no php in it • there are 4 folders inside the websites folder • the folder contains the following file types: .html, .css, .js, .txt, .gif, .png

Hey @tibtubyt,

Really strange. Can you give this a read?

Because there’s no logs (it’s just an upload from your browser) we’re really quite limited in what we can do :frowning: Try different browsers, disabling any plugins and, should anything help, please let us know what! :smile:

All is not lost, by the way. You could always try deploying from a Git provider or using the CLI!

so i should build the file instead of manually uploading it so that there is logs?

Well, sort of! :stuck_out_tongue: It removes the aspect of having to upload files from your browser, more than anything :slight_smile:

it gave me a link ro install something while i was signing into github on the seccond step of creating a build and the link brought me to a dead end (site that wont load)

We have (albeit a bit old) a step-by-step guide on deploying via Git. As you using Git, you should check out GitHub’s guide!

in git the “save” button is greyed out and i cant click on it, and when i go to netlify it still says that it cant connect to git (on step 3 of creating a build)

I’m sorry, I’m not too sure where you’re seeing the ‘save’ option.

Disregard Netlify for now – let’s get your site uploaded to Git (GitHub, I presume?) It should be as simple as this! :slight_smile: