Site won't deploy / "0 new files to upload"

Briefly summarize the issues you have been experiencing.
I’m trying to figure out why my deployment isn’t working

not getting any errors on the deployment itself.
It’s a standard Angular App

build command is npm run build
Publish directory is dist

Please provide a link to your live site hosted on Netlify

What have you tried as far as troubleshooting goes? Do you have an idea what is causing the problem?

tried changing build command to ng build and the publish directory to dist/ so far no joy.

Do you have any other information that is relevant, such as links to docs, libraries, or other resources?

When you run your build command on your local system, are there files in your dist directory?

The final messages shows there are 0 files to upload, so nothing gets deployed.

10:59:39 AM: Creating deploy tree 
10:59:39 AM: 0 new files to upload
10:59:40 AM: Site is live
10:59:39 AM: 0 new functions to upload
11:00:27 AM: Finished processing build request in 1m45.553124322s
1 Like