Site NS Not resolving

My site is https://n8y.netlify.app/ and custom domain is http://dev-n8y.cf/. The n8y.cf domain seems not to be resolving for me. It has been around 12 hours, and usually I see a change by now.

Hi @FF6N8Y Welcome to the Netlify community :netliconfetti:

Is your domain n8y.cf or dev-n8y.cf? Or both?

I have tried a few tools and am unable to find any records (NS, A, CNAME, etc.) for either domain.
From what I see it is still registered to Societe Centrafricaine de Telecommunications/Centrafrique TLD B.V. who are the .cf administrators.

Did you per chance register the domain through freenom as a free domain name? I remember seeing them a number of years ago. Do they offer the ability to change NS, or set custom A, CNAME, MX, and other records?

1 Like

Bang on the money – there are no NS records associated with the domain.

@FF6N8Y, you’ll need to add the NS records at your registrar. You can find what these records are by clicking this warning in our UI:

Hi, the site is: dev-n8y.cf

image

it is through freenom. I am also having that issue of not seeing the NS changed. I have tried twice now to change them.

Yes, they do offer DNS management.

Hi,

I have added in the nameservers, as I said in my post:

It may be an issue with freenom? I can try and get another domain and see if it is a domain issue at freenom.

Perhaps!

The NS records haven’t propagated. It’s either due to a longer propagation which will need some more patience, or an error at your registrar. Likely the former. :slight_smile:

1 Like

That could be the case.
I have just purchased and added the name servers to the domain:
wdn8y.ml we will see what happens and what domain loads the fastest I guess.

@Pie @coelmay
That was confusing. The new domain that I literally just registered a few minutes ago is already propagated and is working! I am now trying to delete the the old domain and just make this one the primary.

Looks like you’ve removed the Netlify DNS zone, meaning you’ll now want to configure the CNAME and A record that our UI specifies (instead of the NS records).