Home
Support Forums

Site not updated despite updates on github

I have updated files locally and pushed the changes to my github remote repo but there are no updates on the websites.

Hi @benmwasambo

Are you seeing deploy logs for the updates you have pushed to git? e.g.

Have you locked your site(s) to a specific deploy? e.g.

Do you have a service worker or are you using caching?

Have you tried viewing your site(s) using multiple browsers, private/incognito windows, and/or different devices and networks to eliminate local caching?

@coelmay Here is the screenshot

@coelmay deploy log

So the log indicated the directory public is set as the publish directory. It also shows that no new files were uploaded which means there is nothing that has changed since the last deploy.

It appears you are using hugo, but you are not building from your git repository. Does this mean you are building locally and pushing this build (I assume in public) to remote?

@coelmay Sure. The building happens locally then changes are pushed to the remote repo, which I expect to auto-update the site.

@coelmay Changes appear to reflect within the master branch of the repo. All files are up to date.

I can see public/media/CV.pdf was updated 4 hours ago. Comparing the version in GitHub to that on your site, they appear the same. I see some files in content have been updated since then, but as you don’t use Netlify to build and are publishing the public directory you have built locally, these changes are not deployed.

@coelmay , I used the same procedure to update the public/media/CV.pdf and the changes were reflected on my site. Any leads to deploying the rest of the changes from the public directory?

The last change to any other file in public was 11–14 months ago, so I dare say there are no changes in public that aren’t already deployed.

@coelmay , Here is my concern, see the screenshot attached. The files on GitHub (content & public folders) have been updated, I have confirmed that they are up to date.

I agree. But I mentioned previously, only your CV.pdf file was updated in public (and I believe that file is now live).

As you are not using Netlify to build, and are simply deploying the files inside public (as per the deploy log) the files in content are never looked at by Netlify, and are never deployed.

Have you managed to get your site updated @benmwasambo, or are you still having issues?

@colmay , I tried to move the files inside public but could not deploy.

The index.md file added to public/project/Seedling-Dashboard/ is available at https://benmwasambo.netlify.app/project/Seedling-Dashboard/index.md.

Netlify (as explained earlier) only deploys the files you place into public, it does not build them because you have not instructed it to do so (as per the screenshot of the deploy log you provided.) If you wish to have Netlify build your site based on the content you have pushed to git (and thus not need to build locally) then you will need to configure your build.