Site not accessible via mobile

When visiting www.statsandr.netlify.app I have the same issue.

However, when visiting statsandr.netlify.app here is what I have:

There is an issue with the layout: the icons in the footer are not displayed and there is no white space on the left edge (next to the bullet points).

That’s just strange. Everything seems to load absolutely fine here. Try using a VPN and see if it works, because if it does work, it’s definitely some ISP problem (even though you did test it on multiple ones).

Did you load it multiple times ? Because sometimes it works the first couple of times, then the problem appears on the third or fourth try.

I had not checked so, but now I did. https://www.dropbox.com/s/1jvaw6zzoupr7iz/Recording.mp4?dl=0

Thanks for trying.

Here is exactly the problem in video: https://drive.google.com/file/d/1KTssToCnfQZiEUaJMqfUTbtzMbrZMp2e/view?usp=sharing

Sadly, I still can’t get the error. https://www.dropbox.com/s/iz1k3zxgstz2hvx/Recording2.mp4?dl=0

I tried almost the same thing as your recording. Only once the website took too long to load, which might be a connection issue on my end.

As I suggested above, would it be possible for you to try using a VPN or ask someone from a different location to check? If we can narrow it down to what’s exactly causing the issue like the internet, or the location or something, it will help tackle the problem better.

is there a possibility you have a service worker running that is causing some problems?

Thanks for your help.

How could I know if there is a service worker on my site?
And if there is one, how could I disable it?

Sorry, I am really not an expert at all.

There’s none. It’s not a servie worker issue. However, if you had one before, it might be possible it’s still cached.

Thanks for that!

I emptied the cache before doing the video.

I’ll try to use a VPN as soon as I managed to understand how it works :slight_smile:

However, that doesn’t explain why 4 of my friends at different location (in Belgium) have the same issue, or does it ?

That definity doesn’t explain it. Sadly, I don’t think it’s possible to give an explanation for me. However, I can suggest one thing. If you can capture the HAR, maybe Netlify support engineers can check it. It’s easy to check it on computers and Android, I don’t know how it’s checked on iPhones sadly.

Please note that I recently changed the base url from www.statsandr.com to statsandr.com, see: https://github.com/AntoineSoetewey/statsandr/blob/master/config.toml#L1

I believe I made all changes regarding this new url in Netlify:

and regarding the SSL certificate:

According to me, that change doesn’t really mean anything. It’s only a matter of choosing which version to serve, the www one or the non-www one. The setup you’ve done in Netlify looks fine, so if it’s working this way, you’re good to go.

1 Like

I just tried with my iPhone on another wifi, the issue is happening too so it has nothing to do with my internet service provider.

Also something I figured out: the issue is happening only on iPhone.

Any developer available to fix this issue? I’m willing to pay as it’s quite a critical issue.

Just on your iPhone or any iPhone? Like, I would still think this has to be some local issue, but can’t say for sure as so much troubleshooting didn’t work.

All iPhones unfortunately

For those who have the same issue or who are interested, the issue is fixed:

It was due to an incorrect DNS record regarding mailchimp. Removing this wrong record fixed the issue.

Thanks everyone for your help!

1 Like

Just checked it on mobile Google Chrome and it’s working.

Thanks for trying. The issue is indeed solved.

1 Like